+ Reply to Thread
Page 8 of 18 FirstFirst ... 4 5 6 7 8 9 10 11 12 ... LastLast
Results 106 to 120 of 259
Like Tree18Likes

Thread: [Addon] KaruulAlert - Karuul's Alerting System

  1. #106
    Soulwalker Feriath's Avatar
    Join Date
    Aug 2013
    Posts
    17

    Default

    I got problem too - alerts for abilities sometimes randomly dissapear. Idk when it's happen, after death or smth else trigger it, but it seems like random. And ONLY alerts for abilities dissapear, alert for buffs always good and fine. The most annoying - "/reloadui" doesn't help me, neither restart game. The only one that works is MANUALLY change something in that ability settings in kalert (like disable-enable it, or disable-enable warnings for it). That's actually painful to do everytime when that bug appears. Any ideas how to fix this? And is there still even someone working on this addon because last update was 25 June? -_-

  2. #107
    Prophet of Telara Frailaq's Avatar
    Join Date
    Jan 2012
    Posts
    1,181

    Default

    Not sure if this can be fixed or if it's just something we have to live with but I use a kalert for the buff provided to my necro pet from casting Ignite and if the pet has to get resummoned then the kalert won't show until I target the pet once. Same thing happens when getting summoned to a rift or shard hopping. Anyways, it's a fairly easy workaround to just click the pet portrait once and then keep going and it's not a huge deal once you know about it but would still be nice if it could be fixed. Then again, maybe my kalert is set up incorrectly.

    *EDIT* Apparently this same issue was brought up before: http://forums.riftgame.com/technical...ml#post4414099
    Last edited by Frailaq; 09-17-2013 at 09:45 AM.
    Avatar by Rotaken on deviantART.

  3. #108
    Soulwalker
    Join Date
    Oct 2011
    Posts
    20

    Default

    Quote Originally Posted by Feriath View Post
    I got problem too - alerts for abilities sometimes randomly dissapear. Idk when it's happen, after death or smth else trigger it, but it seems like random. And ONLY alerts for abilities dissapear, alert for buffs always good and fine. The most annoying - "/reloadui" doesn't help me, neither restart game. The only one that works is MANUALLY change something in that ability settings in kalert (like disable-enable it, or disable-enable warnings for it). That's actually painful to do everytime when that bug appears. Any ideas how to fix this? And is there still even someone working on this addon because last update was 25 June? -_-
    ^^^^ this.

    Ive been running Karuulalert for some time now, and its safe to say its one of the best addons out there.

    I'be been getting those problems lately, where the addon is showig up wrong timers on my debuffs or no timers at all. Its goes fine on most encounters or when parsing on dummies. But on some raid enviroment, sometimes its just shows the wrong time for me to reaply my skills letting this way the debuff fall. As example, i track Pucture bleed, Impale and jagged strike when running sin spec. i set puncture to show up was warning on my screen with 3 secs left on the debuff. some times the debuff falls and i dont get the alert, or when the debuff timer reaches 0, i get the warning showing me 3 secs left. Same goes for Impale.

    Ive usually run my alerts without filling the "buff lenght" field. Ive tried setting buff lenght for those alerts as the exactly time they suppose to last, but still bugs out same way.

    im just 100% sure im not seeting up my alerts wrong , since the only time they seem to bug out is on raid enviroment and at some encounters. Anyone else had this issue?

  4. #109
    RIFT Guide Writer Redcruxs's Avatar
    Join Date
    Jan 2011
    Posts
    3,935

    Default

    it happens to me once or twice a week. The alerts just fail to load at the start of an ecounter

    I usually just /reloadui after the fight and it fixes itself. Sometimes they just randomly start working again mid-fight but it's rare.

    Not too big of a deal

  5. #110
    Rift Disciple
    Join Date
    Nov 2011
    Posts
    164

    Default

    Does anyone have an alert for combat banners? I'd like an alert to show when they are missing so I know to redrop them, but I can't seem to figure out how to get one to work.

  6. #111
    Shield of Telara
    Join Date
    Jan 2011
    Posts
    758

    Default

    Banner for concentration
    Code:
    KA:Banner of Concentration:aXA2LeNpVTssOgjAQ/BW+QNsqitmTLTTxoCRYbySkQkmaSEtK
    Pfj3Lo0XM3uYfczMAgUF80t/TICVKpBwf0+TdxnXzpmQ+TET3vXGxaCj9Q7OuSypYFxydkJaCCAo
    lQiCaOwYodRRb9vHpbXRTJ3tvVvaZ7LrZh9it/RoxPRmGBY4HYEyksO+WIsi/uN4rVR9FdVNVQ0u
    0wWFHUmJvzF2Cg7pA/kFug9A1A
    Banner for fortitude

    Code:
    KA:Banner of Fortitude:a7Bw9eNotjVELgjAUhf+Kv6A2NRucJzMHPZRg602QkTMHuoXOoH/f
    JsE93HvP5dwPFALvUX7VjDAKcNzXabImOklj1BzZPuJ2dtqtnUKeZCzmOc8TdmBlkXIQH+MInaDW
    vcNZOrlvHpdGOzW1+mnN0vSjfLXLpN3QDvKjTCt3XbeAksQrPiJloWh45VE4VUJU16K8ibL23nag
    SIjHCPxtvwlkG5j/AOW1Ozk

    Banner for Rage

    Code:
    KA:Banner of Rage:aN7lbeNotjcsKwyAQRX8lX9CqkdQyq7yELtqAtbtAkMQEIWox6aJ/XyPlz
    GLuHYYDGCS8V/XVAY5VAofnx1rvsko5p0Pm50yoRUNJGK1ZjsuSUsY5aQDFDx5BEWHmHRq1q3P/u
    vVm13Ywo3dbP69qGUzwbhhNGFd9mqYNSHEFTNAFKDsGR5Kj6qTs7nX7kK2IXTpgyFHS/OuYJBRJy
    3+ykDf+
    Banner for Zeal

    Code:
    KA:Banner of zeal:aMHBIeNotjcsKgzAQRX/FL2gTLVq5Kx8JdNEKNt0UQQaNrRBjUbvo3zcN5
    cxi7h2GAw6Fl6GPXvBbFSSu72mabZCTtXoJ5iG4azLIWJIlYRqJMC4KwVgM5j6kgznqcdhQ0kb75
    nZqxk1P7djNdm0GQ4+Wlo6sbp9k+13fr0gTcM6POPjhDq/IK6WqcyEuStSu8weOiHnLv3ZJIfZW+
    QVx8zet

  7. #112
    Rift Disciple
    Join Date
    Nov 2011
    Posts
    164

    Default

    Score!

    Thank you!

  8. #113
    Shield of Telara
    Join Date
    Jan 2011
    Posts
    758

    Default

    Quote Originally Posted by Inshalla View Post
    Score!

    Thank you!
    These alerts I posted show when they are active. They do not show when they are missing. Considering you can only have two up, having it show when things are not there would be odd.

  9. #114
    Shadowlander
    Join Date
    Feb 2011
    Posts
    39

    Default

    Error: kAlert/tasks.lua:53: Incorrect function usage.
    Parameters: (userdata: ), "Data/\UI\ability_icons\tactician_empyrean_bolt.dds", "1260"
    Parameter types: userdata, string, string
    Function documentation:
    Sets the current texture used for this element.
    Texture:SetTexture(source, texture) -- string, string
    Parameters:
    source: The source of the resource. "Rift" will take the resource from Rift's internal data. Anything else will take the resource from the addon with that identifier.
    texture: The actual texture identifier. Either a resource identifier or a filename.
    stack traceback:
    kAlert/main.lua:848: in function 'add'
    kAlert/main.lua:905: in function <kAlert/main.lua:893>
    [C]: in function 'xpcall'
    kAlert/tasks.lua:49: in function <kAlert/tasks.lua:42>
    In kAlert / unnamed background task
    stack traceback:
    [C]: in function 'error'
    kAlert/tasks.lua:53: in function <kAlert/tasks.lua:53>
    [C]: in function 'xpcall'
    [C]: in function 'Dispatch'
    kAlert/tasks.lua:53: in function <kAlert/tasks.lua:42>



    I keep getting this message started today, have no idea why, I didn't change or add any alerts.
    Any ideas on how to fix it? reinstalling the game is the only thing I have not tried yet, have deleted all saved files yet still get this error as soon as I import a set.
    any help would be awesome

  10. #115
    Prophet of Telara Frailaq's Avatar
    Join Date
    Jan 2012
    Posts
    1,181

    Default

    There's an issue floating around that seems to stem from receiving a shared alert that is corrupt. There are a couple of way to fix this ranging from the extreme of deleting every alert you have down to figuring out which alert is causing the problem and removing them.

    *Note: if you encounter ANY kalert error message while going through the following steps you will have to /reloadui before continuing or you will miss bad alerts (the first error message prevents the next one from showing up).

    Step 1) Edit Layout
    Go through every Set and Subset you have that contains alerts and hit Edit Layout on each of them. If you get an error message and the layout doesn't show any alerts write this Set/Subset down for further review, then do a /reloadui and go back to testing the rest of the sets. This will give you every Set or Subset that has a bad alert in it.

    Step 2) Test phase 1
    Go to a set that has a bad alert and one at a time Move each alert to a new set (move them to a currently blank set). If any of the Moves produces an error, write down the name of the alert for later review and then do a /reloadui. Verify that you know how to recreate any of the bad alerts and then delete them.

    Step 3) Test phase 2
    For some reason, neither Test phase 1 or Test phase 2 by itself seems to catch all the bugs. I had to go through both phases. Double click on each alert one at a time so that it opens the alert settings. If you get an error message, write down the alert and /reloadui before continuing. Delete all bad alerts.

    Step 4) Confirmation
    Use the intial Edit Layout trick to confirm that your kalert is once again fully functional. Every Set and Subset should be tested and any of them that have alerts should show the alerts during the edit layout mode. If you get any errors, rinse and repeat, you probably just missed an alert.

    Step 5) Recreat needed alerts
    All those alerts you just deleted... assuming you still need them go ahead and recreate them. Also, make sure to move alerts back to the sets/subsets you need them to be in. The ideal solution is to set Role specific alerts to the Sets and include a "kalert set=X" line in your change role macros and then throw Boss specific alerts into subsets. (Some people break subsets into raids so all TDQ alerts go in Subset 1, FT alerts in Subset 2, etc. but I just throw all boss alerts into Subset 1)

    And you should have a working kalerts again. To help prevent this problem in the future, take note of any kalert that is shared with you and if you have time then, test it using Edit Layout mode to make sure it's not broken so you don't have to go back and do all this craziness again. I had to remove about 8 alerts before mine was fixed.

    *Note2: You don't have to do all this.... you can just delete every alert and recreate them all from scratch if you so desire. Just realize that if you do that you're on your own. Best of luck to you.
    Last edited by Frailaq; 10-18-2013 at 05:54 AM.
    Avatar by Rotaken on deviantART.

  11. #116
    Rift Disciple
    Join Date
    Nov 2011
    Posts
    164

    Default

    Quote Originally Posted by Daayou View Post
    These alerts I posted show when they are active. They do not show when they are missing. Considering you can only have two up, having it show when things are not there would be odd.
    I switched to the Missing check box. Banners haven't been my responsibility for all that long so I forget on occasion. However, once the banner is up, I don't really care about it anymore. I just care when it's not there. I have added it to my Buff/Debuff alert block.

    Thanks again.

  12. #117
    Champion R0NlN's Avatar
    Join Date
    May 2011
    Posts
    534

    Default Possible to set an Alert to only go off while in a group?

    I have an ability that is used on an "ally" (Righteous Mandate). However, I spend a good deal of time soloing.

    I would like to set an alert to remind me when Righteous Mandate expires, but only have it go off when I'm in a group. Is there a way to get KAlert to only check for Righteous Mandate when I'm in a group?

    Thanks!
    Last edited by R0NlN; 10-18-2013 at 11:30 AM.

  13. #118
    Rift Disciple Thorarin's Avatar
    Join Date
    Oct 2011
    Posts
    136

    Default

    Quote Originally Posted by Nitrous22 View Post
    Error: kAlert/tasks.lua:53: Incorrect function usage.
    Parameters: (userdata: ), "Data/\UI\ability_icons\tactician_empyrean_bolt.dds", "1260"
    Parameter types: userdata, string, string
    If you imported an alert (or someone shared it) for Eggtender's Bile Faucet, try deleting that one. Or if you actually have an alert for Empyrean Bolt

    Unfortunately I've not been able to reproduce the issue where some alerts seem to get currupted. I've shared this type of alert back and forth but it works fine. If anyone has a solid repro case, that would be useful.
    Last edited by Thorarin; 10-18-2013 at 01:03 PM.

    KaruulAlert maintainer/co-author (Curse / Rift UI)

  14. #119
    Rift Disciple Thorarin's Avatar
    Join Date
    Oct 2011
    Posts
    136

    Default KaruulAlert v1.39.1 released

    KaruulAlert 1.39.1

    Outlined text now makes use of Rift 2.3+ features in order to display. This should slightly increase performance.

    Fixed some data corruption that occurred when sharing or exporting a newly created alert.

    KaruulAlert will ignore alerts that have been shared using an older version if it has been corrupted. Importing alerts that were incorrectly exported will refuse to import with an error message. Alert sets containing corrupted alerts will still import, but the broken alerts will be ignored.

    Fixed the Export Alert function which was broken in v1.39.0. Shortest lived version ever ;)

    Some ongoing rewrites have been made to be more compatible with future versions of Rift.


    Notes:

    If you are currently experiencing error messages due to corrupting alerts, merely updating to this version will unfortunately not fix your problem. Doing that kind of a fix would have taken much much longer to make and test, and I wanted to prevent the issue from spreading further ASAP.

    In general, I would suggest you:
    1. Ignore any error popups you might get
    2. Type /kalert to open the main dialog
    3. Rightclick the offending alert and select Delete

    Find out exactly which alert is causing the issue can be tricky, but I would suggest starting with the ones that you recently imported.

    I hope that helps.
    Last edited by Thorarin; 10-19-2013 at 01:24 AM.

    KaruulAlert maintainer/co-author (Curse / Rift UI)

  15. #120
    Champion
    Join Date
    Mar 2011
    Posts
    540

    Default

    Would it be possible to implement a way for alerts to distinguish between 2 procs with the same name (going by ability IDs maybe?)?
    The RB crystal procs 2 different procs (one on triggering a burst, one when casting Rift Implosion) both named "Calliope's Glowing Riftblade Crystal", same icon and both trigger an alert set up by its name which makes it useless.
    Trion didn't really think this through in that regard, I'd assume it's the same for the lower Tier crystal (which I no longer possess).

+ Reply to Thread
Page 8 of 18 FirstFirst ... 4 5 6 7 8 9 10 11 12 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts