+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 16 to 29 of 29
Like Tree11Likes

Thread: add on request - rares in VP

  1. #16
    Champion caduto's Avatar
    Join Date
    Oct 2011
    Posts
    535

    Default

    ok.. so on sunday when the bug happened again, i killed c1a3 first, it didnt register as killed.
    on monday, i killed C2A1 first and then C2A2 and then C1A3, when i killed them in that order they all registered and ticked off the list.
    today (tuesday) i killed C1A3 first and again it is not ticked off the list. it doesnt come up in the chat as being killed either. i then killed the other two and they both registered correctly.

    it seems to matter which order you kill them in!

    i typed in '/killlist debug' and it came up with the line in chat to say debug was activated but didnt say anything else.. should i be seeing something else my end?

  2. #17
    Soulwalker
    Join Date
    Jun 2011
    Posts
    22

    Default

    I will only display something when invalid kill is registred.

    I don't remember in what order I did them, I will try this way
    Wicendawen@Brisesol
    Updated KBM for 4.2

  3. #18
    Champion caduto's Avatar
    Join Date
    Oct 2011
    Posts
    535

    Default

    just killed all 3 again with C1A3 first and they all registered correctly this time..
    im now at a loss as to what the issue is..
    its not terribly consistent lol

  4. #19
    Champion aileen's Avatar
    Join Date
    Mar 2011
    Posts
    573

    Default

    Quote Originally Posted by caduto View Post
    just killed all 3 again with C1A3 first and they all registered correctly this time..
    im now at a loss as to what the issue is..
    its not terribly consistent lol
    I think problem relies that addon checking for killing blow done by you, so if anyone else tagged rare and killed, it doesn't recognized you killed it.
    RemoveBuff a simple addon for replacing cancelbuff command.
    a.k.a Aileenbor <Special Olympics> @ Icewatch

  5. #20
    Champion caduto's Avatar
    Join Date
    Oct 2011
    Posts
    535

    Default

    Quote Originally Posted by aileen View Post
    I think problem relies that addon checking for killing blow done by you, so if anyone else tagged rare and killed, it doesn't recognized you killed it.
    possibly.. but the amount of times we kill these as a group would outweigh that as being a posibility.
    i often tag it once and then others do the full kill to ensure they get credit too.. its unlikely that im getting the killing shot at those moments, however not impossible.

    also, i multibox quite often and the rares are ticked off on both accounts.. so probably not the case

    either way, the add on is still super usefull
    Last edited by caduto; 09-07-2017 at 09:55 AM.

  6. #21
    Champion caduto's Avatar
    Join Date
    Oct 2011
    Posts
    535

    Default

    been getting this a lot lately..
    http://i.imgur.com/B2vsEa3.png

    murder bot was killed and i got loot, but it didnt tick off the list.
    its happening 2 or 3 times day with various different rares

  7. #22
    Soulwalker
    Join Date
    Jun 2011
    Posts
    22

    Default

    Someone at tag him before you, that why you are getting this debug message.

    In fact I don't use the killing blow to determine who killed a mob, however I check if the mob was tag, but it look like the API only register the first player that have tagged a mob

    For now I don't know how to solve this issue, I have a few ideas I need to test.
    Wicendawen@Brisesol
    Updated KBM for 4.2

  8. #23
    Champion caduto's Avatar
    Join Date
    Oct 2011
    Posts
    535

    Default

    Quote Originally Posted by kinou View Post
    Someone at tag him before you, that why you are getting this debug message.

    In fact I don't use the killing blow to determine who killed a mob, however I check if the mob was tag, but it look like the API only register the first player that have tagged a mob

    For now I don't know how to solve this issue, I have a few ideas I need to test.
    ah i see!
    i am pretty much always grouped up with my husband when we kill these, we either both get credit for the kill or both dont.
    but yes, this seems to be happening when we engage the mob and someone else is already there killing it.
    would you like us to take notes over the next few days for more accurate data?

  9. #24
    Soulwalker
    Join Date
    Oct 2012
    Posts
    19

    Default

    Thank you for your work on this addon. Sadly, I am getting a number of errors when I try to load it (version 0.5).

    When I enable the addon I first get 6 identical error messages

    Error: KillList/main.lua:120: attempt to call method 'SetCloseButtonVisible' (a nil value)
    In KillList / initialize display, event Event.Addon.Load.End
    stack traceback:
    [C]: in function 'SetCloseButtonVisible'
    KillList/main.lua:120: in function <KillList/main.lua:113>
    If I then open the addon using /killlist, I get another error

    Error: KillList/main.lua:166: attempt to index field 'row' (a nil value)
    In KillList / display VP rares not yet killed today, event Event.Slash.killlist
    stack traceback:
    [C]: in function '__index'
    KillList/main.lua:166: in function 'show'
    KillList/main.lua:187: in function <KillList/main.lua:176>
    At this point I'm staring at blank window named 'KillList testframe' without any content or buttons, and the only way to get rid of it is to turn off the entire addon.

    Hope this information is useful to you.

  10. #25
    Champion caduto's Avatar
    Join Date
    Oct 2011
    Posts
    535

    Default

    is there anyway to switch off the debug info again?
    having typed in '/killlist debug' im not getting a lot of white text every time someone else kills a rare around me

  11. #26
    Soulwalker
    Join Date
    Jun 2011
    Posts
    22

    Default

    You just have to do "/killlist debug" another time.

    Tevash: I will release a new version this weekend that should fix this
    Last edited by kinou; 09-14-2017 at 12:21 AM.
    Wicendawen@Brisesol
    Updated KBM for 4.2

  12. #27
    Soulwalker
    Join Date
    Jun 2011
    Posts
    22

    Default

    I have release the 0.6, I think i will fix your problem
    It also add a button to display the list
    Wicendawen@Brisesol
    Updated KBM for 4.2

  13. #28
    Rift Disciple
    Join Date
    Jan 2011
    Location
    Behind you!
    Posts
    143

    Default

    Just want to say thanks, this is a really awesome add-on.

  14. #29
    Soulwalker
    Join Date
    Oct 2012
    Posts
    19

    Default

    Thank you for the update, that did indeed remove the errors I was getting, all working fine now, thanks again!

+ Reply to Thread
Page 2 of 2 FirstFirst 1 2

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts