+ Reply to Thread
Results 1 to 3 of 3

Thread: Command.Message.Broadcast into channel

  1. #1
    Champion
    Join Date
    Jun 2011
    Posts
    561

    Default Command.Message.Broadcast into channel

    Hi guys

    For the first time I'd need to broadcast some stuff into a channel. Looks like I'm doing something wrong, cause I can't get it to work:

    Command.Message.Accept("channel", "nktest@Typhiria")

    Command.Message.Broadcast("channel", "nktest@Typhiria", "nkTest", "sample", _test)

    Command.Event.Attach(Event.Message.Receive, _fctProcessMessage, "nkTest.Message.Receive")
    Everything works if I for example use 'guild' as target. However I can't get channel to work.

    Someone got an idea what I'm doing wrong?

    Cheers
    N.

  2. #2
    General of Telara
    Join Date
    Mar 2014
    Posts
    967

    Default

    Hm I haven't used it myself, but looking at the docs and also Conquest Tracker, it looks to me like you're using Command.Message.Accept() incorrectly. The second argument should be the identifier you used in Command.Message.Broadcast(), which is argument #3.
    So in you example it should be:
    Command.Message.Accept("channel", "nkTest")

    Though it seems weird why it works for guild messages then if the identifier was wrong.
    Dimension Addon 'Tinker Tools' is now available on Curse!
    Or grab the latest development code on GitHub.

  3. #3
    Champion
    Join Date
    Jun 2011
    Posts
    561

    Default

    Hi

    Ahhhhh I knew it was something simple. Thanks for the hint. It works know.

    Guild did work cause it were different message from another addon. Wasn't my best day yesterday obviously

    Cheers
    N.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts