+ Reply to Thread
Results 1 to 2 of 2

Thread: Placing a dimension item but it disappears

  1. #1
    Rift Disciple Silir's Avatar
    Join Date
    Mar 2011
    Posts
    134

    Default Placing a dimension item but it disappears

    Command.Dimension.Layout.Place

    Most of the time when I call this method it places the object correct.
    Sometimes, it tells me object is placed.

    But I don't get a Event.Dimension.Layout.Add event fire - which means it has appeared too far for me to see (I think).

    Then I use the built-in dimension tools and select the last item that was added - Rift will tell me that object is too far out of my reach, but will allow me to pickup the object back into my inventory.

    So the questions are:

    Why is Place call failing.
    Do other players encounter this, and is there a workaround?

  2. #2
    Rift Disciple Silir's Avatar
    Join Date
    Mar 2011
    Posts
    134

    Default Bug? Did I hit some sort of dimension boundary??

    This is super weird.

    This bug happens whenever I try to place the object at coordZ = 300

    I'm in Faen's Retreat.

    Placing a dimension item but it disappears-2013-10-25_232040.jpg

    See the line of missing cubes? That's coordZ = 300.

    I changed my code so that it inserts the cube at 300.0001
    There's no visible difference, but the cube now inserts correctly.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts