+ Reply to Thread
Results 1 to 10 of 10
Like Tree3Likes
  • 2 Post By Thorarin
  • 1 Post By Baanano

Thread: [BUG] Problems with text fields

  1. #1
    Rift Disciple Thorarin's Avatar
    Join Date
    Oct 2011
    Posts
    136

    Default [BUG] Problems with text fields

    I have been getting a lot of reports of text fields not working in KaruulAlert, but I was unable to reproduce it, until now.

    Other addons are also experiencing this same issue. It turns out that it is related to the Global UI Scale option (under Settings - Interface - Display).

    If you are experiencing issues with text fields in your addons, turn off global UI scaling until Trion fixes this issue.
    Last edited by Thorarin; 02-28-2013 at 12:07 PM.

    KaruulAlert maintainer/co-author (Curse / Rift UI)

  2. #2
    Plane Touched
    Join Date
    Feb 2012
    Posts
    228

    Default

    Turning this off doesn't work for me. Turning it on, using a value of 100%, does, but it looks really ugly.

  3. #3
    Prophet of Telara
    Join Date
    Jun 2011
    Posts
    1,199

    Default

    Quote Originally Posted by Baanano View Post
    Turning this off doesn't work for me. Turning it on, using a value of 100%, does, but it looks really ugly.
    Thanks! I couldn't get it to work either by following the OP's suggestion. Only after turning it on and then setting it to 100 did it work.

  4. #4
    Rift Disciple Thorarin's Avatar
    Join Date
    Oct 2011
    Posts
    136

    Default

    Strange that turning it off didn't work for you... perhaps a client restart would be required in some cases?

    KaruulAlert maintainer/co-author (Curse / Rift UI)

  5. #5
    Soulwalker whippost's Avatar
    Join Date
    Aug 2011
    Posts
    4

    Default

    Quote Originally Posted by Thorarin View Post
    Strange that turning it off didn't work for you... perhaps a client restart would be required in some cases?
    I had to /reloadui after turning scaling off for it to fix the addon text fields. Setting the scale to 100 work and didn't require a reload.

  6. #6
    Plane Walker Aesha's Avatar
    Join Date
    Feb 2011
    Location
    Egypt
    Posts
    498

    Default

    This trick worked for me as well. Thanks

    It also fixed:

    Dimension Toolbox
    Gadgets

    On a side note, having to turn off scaling, mean reconfiguring my layout and every addon I have. Since most the addon display positions were now WELL off my screen. Major pain in the @ss.

    And in Rift itself.. I can no longer see the entire Roles screen (having to use command line to change roles..another pita).

    But seriously, thanks Thorarin.

    Aesha
    Aesha @ GELIDRA EU
    Liralen @ FAEBLIGHT NA
    Quote Originally Posted by Caelthas View Post
    I feel like Oliver Twist standing in the Rift Store saying "Please Sir, may I have some more"... because I won't even be able to buy my own lunch after paying for 1/16th of a new dimension.

  7. #7
    Sword of Telara
    Join Date
    Nov 2011
    Posts
    893

    Default

    Quote Originally Posted by Baanano View Post
    Turning this off doesn't work for me. Turning it on, using a value of 100%, does, but it looks really ugly.
    just adjust the display to look really ugly, do what you have to do to adjust the addon, then just turn off the ui scaling once you are done.

  8. #8
    Sword of Telara
    Join Date
    Nov 2011
    Posts
    893

    Default

    Quote Originally Posted by Thorarin View Post
    I have been getting a lot of reports of text fields not working in KaruulAlert, but I was unable to reproduce it, until now.

    Other addons are also experiencing this same issue. It turns out that it is related to the Global UI Scale option (under Settings - Interface - Display).

    If you are experiencing issues with text fields in your addons, turn off global UI scaling until Trion fixes this issue.
    awesome worked for me after giving me a damn headache for hours trying to figure this one out

  9. #9
    General of Telara Foxfire's Avatar
    Join Date
    Dec 2010
    Posts
    957

    Default I found an easier fix for this:

    After trying the suggestions here with no luck, other than turning ON the global gui and setting to 100 which made everything huge, I tried simply changing my screen resolution to the highest setting available. Not sure why I didn't have this in the first place, but doing that, and having global gui turned off (which was off all along anyway) actually fixed the text problem with the dimension toolbox!

    Amazing how something that seemed so difficult turned out to be so easy LOL. Anyway, I wanted to post this in case it may help someone else.

  10. #10
    Rift Disciple Thorarin's Avatar
    Join Date
    Oct 2011
    Posts
    136

    Default

    This problem is fixed in 2.2 hotfix #2.

    It has been replaced by another text field bug related to cursor position, but that should hopefully affect fewer addons in a serious way.

    KaruulAlert maintainer/co-author (Curse / Rift UI)

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts