+ Reply to Thread
Results 1 to 3 of 3

Thread: Quick worried question

  1. #1
    Plane Touched Snags's Avatar
    Join Date
    Dec 2011
    Posts
    229

    Default Quick worried question

    So, just to prepare myself for the worst...

    If I logged on pts and the single most useful addon I have installed gave me this warning:

    Error: Event Event.Unit.Available is deprecated, the addon environment is not in compatibility mode, and addon XXX has an active hook (named UnitAvailCheck).
    In addon XXX / UnitAvailCheck, event Event.Unit.Available
    stack traceback:
    [C]: in function 'error'

    does it mean it'll break come next Wednesday, and it won't be able to be used anymore? It worked fine once I activated the compatibility mode but I won't be able to do it on live, so I'm worried :\

    Thanks to whoever will take his/her time to answer! ^^

  2. #2
    RIFT Guide Writer Noshei's Avatar
    Join Date
    Feb 2011
    Posts
    1,886

    Default

    This is not going to break addons. It is simply a matter of authors updating the addons to remove old commands.

    You will notice a Compatibility mode checkbox in the addon window as well an a similar button on the error window. This will prevent this type of error from showing up for you as it is more important for the author and not the user at this point.

    I do believe however that come 1.11 if the necessary changes aren't made it will break the addon, but thats a bit off still.

    I know a lot of other authors will be releasing 1.10 updates over the next week, so make sure you update your addons.


    Also you might want to post which addon as that can be very helpful.

  3. #3
    Plane Touched Snags's Avatar
    Join Date
    Dec 2011
    Posts
    229

    Default

    Oh, I didn't know you could turn on the compatibility mode on live too... that's a relief! Thanks loads for your answer ^^

    The addon is Click Box Healer... I mainly heal in pvp in rift so having a tool to monitor hots/shields/cooldowns/important debuffs duration on the whole raid at a glance is invaluable, so seeing those errors (well, more the little warning that the addon was likely to break on the next patch) pop up gave me a heart attack

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts