+ Reply to Thread
Results 1 to 3 of 3

Thread: LibSRM - Urgent

  1. #1
    Sword of Telara Semele's Avatar
    Join Date
    Mar 2011
    Posts
    872

    Default LibSRM - Urgent

    Hi everyone.

    There is an edited version of Safe's Raid Manager (LibSRM) floating around with the version adjusted to 1.1.5. I'm guessing this is the case, as the error reports I'm receiving do not match the file structure of my versions which are available for download, or the files supplied with KBM (both are identical).

    Below is the error report I'm getting (and the only one for LibSRM)

    Code:
    12% of reported errors:
    Error: SafesRaidManager/SafesRaidManager.lua:313: attempt to index a nil value In SafesRaidManager / group01_group, event LibUnitChange.group01.Change stack traceback: SafesRaidManager/SafesRaidManager.lua:313: in function 'Leave' SafesRaidManager/SafesRaidManager.lua:402: in function 'Change' SafesRaidManager/SafesRaidManager.lua:461: in function <SafesRaidManager/SafesRaidManager.lua:461> LibUnitChange/main.lua:49: in function <LibUnitChange/main.lua:18>
    The problem is, that Line 313 is empty spacing. And, Line 402 is a call to Inspect.Unit.Detail (not an internal function call) and line 461 is "end" which, as you'd agree none of which makes sense or can be possible (unless, the edited version has a file layout matching the above).

    I'd like to get this rectified with the author who needs to change LibSRM as these errors will cause stability and consistency issues with ALL addons using LibSRM.
    Last edited by Semele; 07-10-2012 at 07:15 AM.
    Rank 76 Guardian Mage

  2. #2
    Telaran
    Join Date
    Mar 2012
    Posts
    72

    Default

    It doesn't look to be MHF. I show the stack trace not making sense with my copy of SRM.

    When I have previously patched things, I added a .1 on the end, eg 1.1.2.1 and 1.1.3.1 are my fault I added the .1 to make rift load my version.

    You can see my 1.1.5 version here:
    http://git.riftui.com/?a=tree&p=Mere...fesRaidManager

    Perhaps someone was trying to fix lifebinder and put the latest srm in and was trying to debug something?

  3. #3
    Sword of Telara Semele's Avatar
    Join Date
    Mar 2011
    Posts
    872

    Default

    Hmm, your 1.1.5 matches mine exactly. I'm pretty sure 1.1.5 behaves fully now, I've not seen it doing anything odd since 1.9.

    Oh well, we'll have to see if I push the version number again see if someone is actively changing it.
    Rank 76 Guardian Mage

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts