+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 17
Like Tree1Likes

Thread: nkAdvisor V2.0.0 gone live (Rift Patch 1.7 compatible)

  1. #1
    Champion
    Join Date
    Jun 2011
    Posts
    561

    Default nkAdvisor V2.0.0 gone live (Rift Patch 1.7 compatible)

    It's been one hell of a work to get nkAdvisor up-to-date with Rift Patch 1.7. This update not only includes the updated database. On top of it there are tons of new features small and big. The most obvious one is a major overhaul of the user interface to make it look more like a standard UI element. This alone meant some serious work on my internal library nkGenie to support textures. Thinkig back at the time I drawed the textures makes me cringe.

    I seriously hope there are no big erros in this one. However as I rewrote the loot table part of the addon externally as well as internally there might be some things I didn't notice. Tested the obvious stuff but as I wanted to get the update out due to the Rift Patch 1.7 item change, there might be things I didn't notice.

    Let me know if anything is not working the way it should at my blog, my email, pm in this forum or bug report on Curse or RiftUI.

    Cheers
    N.

    Version 2.0.0 changelog

    * updated database to Rift Patch 1.7
    * complete internal rewrite of the loot table handling
    * more or less complete UI update - look integrates with standard UI now
    * loot tables show total number of items now
    * updated user interface
    * reorganized and updated PvP loot tables
    * added a lot of missing PvP items and factions
    * reorganized Expert loot tables due to latest Rift Patch
    * added L48-50 normal instances
    * added River of Souls chronicle (only few loot, yet)
    * added Caduceus Rise (no loot tables yet - didn't get any info so far)
    * updated previous chronicles loot tables
    * item tooltips will show neccessary pvp rank if required
    * in-Game Tooltips for most items will be rated - experimental, can bet activated in configuration
    * date of item database import will be shown
    * improved filtering of item database import - less duplicated crafted variants, more entry level variants
    * support for consumables
    * support for lures
    * item search supports trinkets
    * Valor is now a supported stat (rating and tooltip)
    * bug fix: export / import of block stat works
    * bug fix: added a couple of missing factions
    * bug fix: saving rating sets does no longer throw error if tab 2 was not opened before
    * much more I can't remember and which I didn't write down ...

  2. #2
    Plane Touched Custom's Avatar
    Join Date
    Jun 2010
    Location
    Birmingham, AL
    Posts
    218

    Default

    Thank you for your time and work on this. I very much enjoy it.
    To be a healer you have to have a pure heart, one that will always think about others before yourself. My fellow man shall not fall as long as I have breathe. Trust me and stand by my side and you shall always be rewarded with life.

  3. #3
    Telaran
    Join Date
    Dec 2010
    Posts
    52

    Default

    Am I the only one getting massive amount of errors and most of the menus doesn't seem to work? Not sure if I am doing anything wrong though but it seems pretty broken.

  4. #4
    Plane Touched Cerium's Avatar
    Join Date
    Oct 2011
    Posts
    258

    Default

    Quote Originally Posted by RaidSoft View Post
    Am I the only one getting massive amount of errors and most of the menus doesn't seem to work? Not sure if I am doing anything wrong though but it seems pretty broken.
    It usually helps to submit a screenshot of your errors to the author instead of just saying it was erroring.

    just sayin .....
    Quote Originally Posted by BrianMorin View Post
    The more people play Rift and subscribe, the more time and money we have to continue to evolve the game....

    "Cerium, glowers at you dubiously -- looks like he would wipe the floor with you!"

  5. #5
    Telaran
    Join Date
    Dec 2010
    Posts
    52

    Default

    Quote Originally Posted by Cerium View Post
    It usually helps to submit a screenshot of your errors to the author instead of just saying it was erroring.

    just sayin .....
    True but the errors I was getting is MUCH too obvious since it's basically EVERYTHING in the addon that gives errors... This is why I was wondering if it was just me getting this, basically just opening the menu and moving the mouse over anything throws out a whole bunch of errors and most of the buttons doesn't work...

    Not like there's a single feature that isn't working in which case that might be more relevant but now it's the entire thing that isn't working so you think that screenshot Everything would be a good use of time for either me or him since it would be virtually pointless?

    edit: seeing as it seems it's just me I was testing to see what could cause this, I removed and added the addon again but that did nothing, I found a file that had saved settings from the addon and removed that, now the addon seems to be working better.

    I'm going to see if I can replicate what caused this in the first place.

    edit2: I am fairly sure I have found what the cause was, if you check the "compare with current equipment" setting and then uncheck it then it seems to break everything until I delete saved settings for the addon. I sent this in a message to Naifu as well.
    Last edited by RaidSoft; 02-08-2012 at 02:40 AM.

  6. #6
    Champion
    Join Date
    Jun 2011
    Posts
    561

    Default

    Thanks for the info mate. As a general rule of thumb with all of my addons you can expect them to be tested for obvious errors by me and some of my guild mates. So If one of my addons breaks down completely it's always a very unexptected issue.

    My guess from your error description is either:

    - You checked to not compare with current equip and haven't saved your equip to that set
    - You did the above but removed one item from that saved equip from your inventory (sold or destroyed it)

    It will most probably be one of either of these two reasons. In the meantime you could try to save again your equip to that current rating set (button at the bottom) and then uncheck the checkbox. If it no longer throws errors it's definitely one of the above reasons.

    Oh and a screenshot of the error log would be most welcome

    Cheers
    N.

  7. #7
    Shield of Telara MaddBomber83's Avatar
    Join Date
    Jan 2011
    Location
    West Texas, USA
    Posts
    695

    Default

    I also got a bunch of errors on the first load of the addon. It occurred when I first upgraded and then selected the Rate tooltips and did a /reloadui.

    As a result of the errors, I was unable to uncheck that box as the menu would not draw, only the tabs and the loot tables seemed to work.

    Unfortunately I was in a rush with the guild so I did not jot down the error codes. I loaded up the saved data from a prior release (so that the Rate Tooltips box would be unchecked) and this resolved the issue.

    Today, with more time, I played around and was unable to reproduce the error! Bah. If I can get it again I'll give the needed info to track it down.



    A couple of notes about the tool tips experiment. First, it looks great and I think will be very useful in the future.:
    - The tool tip does not 'compare' between equipment currently equipped and equipment being moused over. It seems to ignore the 'compare with current equipment' option.
    - The tool tip always anchors itself on the bottom of the currently equipped item. So if you mouse over a pair of gloves in your inventory, it will show the score of those gloves, but anchor the tool tip on the one for your currently equipped gloves.
    - - - We can get around this by mouse over our current gloves and then the ones in our inventory / loot window and do the math in the head.
    - There does not seem to be a tool tip (from the game) at all for items linked in chat. I'm not sure there is a way you could hook into an item that you click on from the chat window and get scores on that?
    - - - Again, easy to work around by finding that item in your item search tab.

    I thought this add on was amazing when I first got it. Thank you for the constant improvements!

  8. #8
    Champion
    Join Date
    Jun 2011
    Posts
    561

    Default

    Quote Originally Posted by MaddBomber83 View Post
    A couple of notes about the tool tips experiment. First, it looks great and I think will be very useful in the future.:
    - The tool tip does not 'compare' between equipment currently equipped and equipment being moused over. It seems to ignore the 'compare with current equipment' option.
    - The tool tip always anchors itself on the bottom of the currently equipped item. So if you mouse over a pair of gloves in your inventory, it will show the score of those gloves, but anchor the tool tip on the one for your currently equipped gloves.
    - - - We can get around this by mouse over our current gloves and then the ones in our inventory / loot window and do the math in the head.
    - There does not seem to be a tool tip (from the game) at all for items linked in chat. I'm not sure there is a way you could hook into an item that you click on from the chat window and get scores on that?
    - - - Again, easy to work around by finding that item in your item search tab.

    I thought this add on was amazing when I first got it. Thank you for the constant improvements!
    EDIT: Found the bug. It was a combination of things related to the 'compare with current equip' thing and old settings. The next version will try to 'auto-repair' oldish settings. Found a lot of related issues with importing and creating new sets in the same go

    The anchoring is more or less a bug in the API. It will only fire the event properly for the first tooltip and then twice again without any info (twice cause of comparative tooltips and always twice even for leg slots etc.)

    Once the event is run (I hacked a big using timing to get around the bug) the frame will be set to the last tooltip drawn. Another bug in the API.

    Linked items do not run the event for tooltip change - another bug in the API. I think I could display a rating anyway but have to tinker a bit more with my workaround.

    In the end the whole tooltip issue is currently very much working around bugs in the API itself. I'm sure this will improve in the upcoming updates of the API so the tooltip will work properly in any case.

    Cheers
    N.
    Last edited by Naifu; 02-08-2012 at 10:33 AM.

  9. #9
    Champion
    Join Date
    Jun 2011
    Posts
    561

    Default

    Version 2.0.1

    * added / corrected a couple of items to loot tables (not many)
    * separated raid rifts into Tier 1 / Tier 2
    * improved rating info for UI tooltips (coloring and positioning)
    * updated design of confirmation / info dialog when saving equipment for rating set
    * bug fix: German language text of info dialog when saving euqipment for rating set
    * bug fix: adding new rating set will now create the set correctly
    * bug fix: importing a rating set will now create the set correctly
    * bug fix: routine trying to upgrade settings of previous version works better now
    * bug fix: routine trying to figure out rating info for UI tooltips will handle compare to current equip much better - will use current equip if 'saved equip' is to be used and no equip at all or no item for that particular slot is saved

    * updated nkGenie to V1.3.2
    > dialogs now support standard UI design
    > fixed an error that dialogs were using wrong languages for button texts
    > tooltip widget now supports colors for standard lines
    > tooltip widget now works much better if sub values are not used

  10. #10
    Soulwalker Klamor's Avatar
    Join Date
    May 2011
    Posts
    20

    Default

    I'm having the same problem as posted above. I've deleted the addon from my Addons folder, and reinstalled and it still didn't correct the problem. Simply opening the interface ingame causes my chat log to explode with errors. I don't know which file the previous poster deleted to stop this from occuring. Could the users get a little more information on how to fix this, since the newest update to the addon seems to have not.
    Klamor@Seastone
    <Dawn of Terror>
    L60/R63 Warrior Guardian
    Progress: 5/5 EE, 4/4 FT, 4/4 TotDQ
    HMs in the works.

  11. #11
    Champion
    Join Date
    Jun 2011
    Posts
    561

    Default

    Quote Originally Posted by Klamor View Post
    I'm having the same problem as posted above. I've deleted the addon from my Addons folder, and reinstalled and it still didn't correct the problem. Simply opening the interface ingame causes my chat log to explode with errors. I don't know which file the previous poster deleted to stop this from occuring. Could the users get a little more information on how to fix this, since the newest update to the addon seems to have not.
    SavedVariables file in the folder /interface/saved/... below your rift game folder.

    Cheers
    N.

  12. #12
    Soulwalker Klamor's Avatar
    Join Date
    May 2011
    Posts
    20

    Default

    OK, have to delete the entire SavedVariables folder. Thanks Naifu.
    Klamor@Seastone
    <Dawn of Terror>
    L60/R63 Warrior Guardian
    Progress: 5/5 EE, 4/4 FT, 4/4 TotDQ
    HMs in the works.

  13. #13
    Soulwalker
    Join Date
    Dec 2011
    Posts
    1

    Default

    Deleting saved variables doesn't fix it for me. Unless i have to delete the whole folder, not just 2 files from nk.

    EDIT: After countless reinstalling i figured out what was wrong ;) I've put commas in weighs instead of dots ;) That seems to break it.
    Last edited by Fenikt; 02-18-2012 at 07:05 AM.

  14. #14
    Plane Walker Rizz's Avatar
    Join Date
    Jan 2011
    Location
    Stockholm, Sweden
    Posts
    437

    Default

    [Bug]
    If you have role activation active, if anyone in your raid (party only?) changes soul, the role activation actives.

    [Bug]
    If I have "player debuff warning" on (usually only happens on alts), and I'm in a raid, I sometimes get up "Volcanic Bomb", even tho it's the boss that has that debuff, I simply got a buff with the same name.
    Rathi@Gelidra <Invictus>
    IRotP: Conqueror | NM TD: 4/4

  15. #15
    Champion
    Join Date
    Jun 2011
    Posts
    561

    Default

    Quote Originally Posted by Fenikt View Post
    Deleting saved variables doesn't fix it for me. Unless i have to delete the whole folder, not just 2 files from nk.

    EDIT: After countless reinstalling i figured out what was wrong ;) I've put commas in weighs instead of dots ;) That seems to break it.
    Ah that explains a lot. Guess I better include a check for commas in the text entered. Thanks a lot for finding that one!

    Quote Originally Posted by Rizz View Post
    [Bug]
    If you have role activation active, if anyone in your raid (party only?) changes soul, the role activation actives.

    [Bug]
    If I have "player debuff warning" on (usually only happens on alts), and I'm in a raid, I sometimes get up "Volcanic Bomb", even tho it's the boss that has that debuff, I simply got a buff with the same name.
    Wrong thread I guess but anyway thank for the info. If a debuff shows on your and not on the buff it means that the API is reporting it wrongly. Does that debuff on the boss maybe affect the player in any way. What is that "Volcanic Bomb" anyway?

    Cheers
    N.
    Last edited by Naifu; 02-22-2012 at 12:46 AM.

+ Reply to Thread
Page 1 of 2 1 2 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts