+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 28
Like Tree3Likes

  Click here to go to the first Rift Team post in this thread.   Thread: Rift 64 on PTS: Windows 10 users

  1.   Click here to go to the next Rift Team post in this thread.   #1
    Rift Team
    Join Date
    Jun 2014
    Posts
    677

    Default Rift 64 on PTS: Windows 10 users

    Have any of you who are trying Rift 64 on Windows 10 tried out compatibility mode? You could try setting it to Windows 7: https://support.microsoft.com/en-us/...ams-compatible

    Not sure if it'll work but it can't hurt to try, and may help us narrow down the problem.

  2. #2
    RIFT Fan Site Operator Nouvae's Avatar
    Join Date
    Mar 2011
    Posts
    1,680

    Default

    I just tried this:

    Settings applied to: RIFT:
    Windows compatibility mode: Windows 7
    Display settings: Scaling on high DPI
    User Account Control: Run as administrator
    Display settings could have a noticeable impact on the appearance of other programs. After you have tested the program, you must close it to restore the appearance.
    You need to test the program to make sure these new settings fixed the problem before you can click Next to continue.

    Received same errors, crashing at 1% when trying to log into any character.


    Edit to add: I also tried a few times manually changing those settings, as instructed on that page, same error.
    Last edited by Nouvae; 10-08-2016 at 09:29 AM.

  3. #3
    General of Telara
    Join Date
    Nov 2010
    Posts
    979

    Default

    I did this and it caused the game to crash a bit sooner. It now crashes as soon as I hit play and never makes it to 1% loading.

    To be clear: I was crashing after selecting a character and getting to 1% into game. Now crashing when I press play at the character select screen.
    Last edited by Accol; 10-08-2016 at 09:43 AM.

  4. #4
    Plane Touched WorldAdidas's Avatar
    Join Date
    Oct 2014
    Posts
    256

    Default

    It's just not windows 10. I am on 8.1 and still the same Crashing after clicking play on character screen.
    Last edited by WorldAdidas; 10-08-2016 at 10:10 AM.
    NightmareTide :: Cleared!

    Worldadidas@Gelidra

  5. #5
    Prophet of Telara MisterWibble's Avatar
    Join Date
    Mar 2011
    Posts
    1,108

    Default

    Tried all compatible modes down to Win 7, also tried to run Rift with elevated privileges by changing this in the executable's compatibility tab.

    Neither yielded positive results. For me the executable still crashes at the 1% connecting to server phase (this is after character select).

    If there's a specific debug build or command you want me to run, just let me know. I've generated a few full crash dumps using DebugDiag (the client generates a bunch of exceptions on launch too), maybe those are of value.

    Probably unrelated:
    One thing I do get after reinstalling Rift PTS is Glyph giving me error #3142. Copying the assets folder from live, and letting the game patch these files does seem to resolve this error.
    Last edited by MisterWibble; 10-08-2016 at 02:59 PM.


    A Rift screenshot collection.

    Watch me on Twitch

  6. #6
    Telaran
    Join Date
    Jan 2014
    Posts
    92

    Default

    I am on Windows 10 and it's running fine. Just can't copy my character over, but it loads just fine. Haven't had any crashes.

  7. #7
    RIFT Fan Site Operator Nouvae's Avatar
    Join Date
    Mar 2011
    Posts
    1,680

    Default

    I was able to copy another character over fresh, but that character also crashes upon pressing play on the load screen.

  8.   This is the last Rift Team post in this thread.   #8
    Rift Team
    Join Date
    Jun 2014
    Posts
    677

    Default

    Thanks for the assistance everyone, it was worth a try!

    Hopefully I'll have some more news on Monday about the problem, though I can't make any promises, but I'll post in this forum when I have news.

  9. #9
    Prophet of Telara MisterWibble's Avatar
    Join Date
    Mar 2011
    Posts
    1,108

    Default

    Been tinkering with windbg. Crash dump files don't tell me very much, which isn't too surprising I guess. Missing tasty symbols


    A Rift screenshot collection.

    Watch me on Twitch

  10. #10
    Pie
    Pie is offline
    Telaran Pie's Avatar
    Join Date
    Feb 2011
    Location
    West Palm Beach, FL
    Posts
    70

    Default

    Just FYI... I have tried with an old PTS character and a new and am having the same problems already noted above. Last bit of patch gives an error and hitting play crashes everything. Hope you do find a solution tomorrow.

  11. #11
    Telaran
    Join Date
    Apr 2016
    Posts
    62

    Default

    Running fine on Win10 with no tweaks here (and seeing great frame rates). Using an old copied character - have not tried copying again.

  12. #12
    RIFT Community Ambassador Slipmat's Avatar
    Join Date
    Jan 2011
    Location
    Ireland
    Posts
    6,367

    Default

    Quote Originally Posted by Benjamindavid View Post
    have not tried copying again.
    Just to add to that, i copied over my main again last night as i had the issue of not being able to promote it or do anything with it's Guild permissions, funnily enough this new copy was able to get promoted up ranks to Leader with no issue, not sure if this will help.

  13. #13
    Pie
    Pie is offline
    Telaran Pie's Avatar
    Join Date
    Feb 2011
    Location
    West Palm Beach, FL
    Posts
    70

    Default

    Has anyone else tried uninstalling and reinstalling and it worked? I tried but it didn't work. But I am tempted to try again if that might help. Windows 10 btw.
    Last edited by Pie; 10-10-2016 at 01:07 PM.

  14. #14
    Rift Master notawaifu's Avatar
    Join Date
    Apr 2016
    Posts
    676

    Default

    Compatibility did not work

    Code:
    Faulting application name: rift_x64.exe, version: 1.0.0.0, time stamp: 0x57f5e86e
    Faulting module name: rift_x64.exe, version: 1.0.0.0, time stamp: 0x57f5e86e
    Exception code: 0xc0000005
    Fault offset: 0x0000000000006254
    Faulting process id: 0x13a8
    Faulting application start time: 0x01d223036fa05377
    Faulting application path: C:\Program Files (x86)\Glyph\Games\RIFT\RIFT-PTS\rift_x64.exe
    Faulting module path: C:\Program Files (x86)\Glyph\Games\RIFT\RIFT-PTS\rift_x64.exe
    Report Id: 66653510-9968-4f8c-bf49-f9376f4ecbc0
    Faulting package full name: 
    Faulting package-relative application ID:
    I even tried moving the files from C:\Program Files (x86)\Glyph\Games\RIFT\RIFT-PTS to C:\Program Files\Glyph\Games\RIFT\RIFT-PTS. But short of having to reinstall glyph there as well. I dunno. I rage quit and just removed all the pts files.


    Wondering if 64bit is going to be disabled and delayed for the SFP testing? You're going to lose a ton of people who don't/aren't patient enough to edit the glyphclient.cfg file to force into 32bit - since you can't do it in client; (it freezes).
    Last edited by notawaifu; 10-10-2016 at 06:27 PM.

  15. #15
    Prophet of Telara MisterWibble's Avatar
    Join Date
    Mar 2011
    Posts
    1,108

    Default

    Quote Originally Posted by Pie View Post
    Has anyone else tried uninstalling and reinstalling and it worked? I tried but it didn't work. But I am tempted to try again if that might help. Windows 10 btw.
    I did.. twice.. did not help.


    A Rift screenshot collection.

    Watch me on Twitch

+ Reply to Thread
Page 1 of 2 1 2 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts