+ Reply to Thread
Results 1 to 2 of 2

Thread: Arclight Lifter Glitches/Bug

  1. #1
    Plane Touched Nehira's Avatar
    Join Date
    Nov 2013
    Posts
    223

    Default Arclight Lifter Glitches/Bug

    Hey Trion,

    good job on the Arclight Lifter mount, it's really a great mount. However, there are a few things that seem not ok to me, especially for an expensive mount (4500 credits for non-patrons) like this.

    Moving and jumping once looks really weird because the mount/char makes an extra bump in mid air. Why? Video to illustrate it: https://www.youtube.com/watch?v=l3osXZoH3A8

    This mount is amphibious and my understanding of an amphi mount is, that it work on land and that it can ride *on* water and it can dive. But this mount does not ride on water, in fact it dives that deep, that only half of the char head is above the water surface. This looks wrong to me. Video to illustrate: https://www.youtube.com/watch?v=nybLeMYv2a4

    The tooltip of the mount reads, that this mount matches the speed of my fastest mount. Shouldn't it be 155% and the one you can buy at the vendor be 60%, just like the Arclight Rider mount that was fixed afterwards?

    It would be really nice if you could fix these glitches, because they are annoying and not what one would expect for such an expensive mount. Thanks.
    Nehira@Zaviel
    <The Fires of Heaven>

    Nehira@Hailol
    <Coriolis>

  2. #2
    Telaran Odteg's Avatar
    Join Date
    Aug 2014
    Posts
    73

    Default Wish I had your problems!

    I wish I could complain about my sweet-freakin-slick Arclight mount!

    No for real, I get your reporting legit bugs, I'm just jelly.
    o==(>>>>>>>> ODTEG <<<<<<<<)==o

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts