in the forum footer it says you're running vBulletin version 4.1.3. you should be running at the minimum version 5.x.x, worst case scenario the latest release for 4.x.x.

all top tier, out of the box, forums and CMSs today are heavily exploited by malicious attacks on a day-to-day. it's bad enough that you could fall prey to a 0 day exploit. with that in mind, the first line of defense is to make sure your forum software is up to date to take advantage of the latest security fixes.

there is a particular vulnerability that currently affects vBulletin versions 4.2.2 and older so the Rift forums are currently at high risk.

as I don't use vBulletin myself I'm not really sure how old version 4.1.3 is, but it should be incumbent upon whoever is in charge the security of the forums to keep them up to date on a regular basis.

if you found this suggestion useful, I do accept tips