+ Reply to Thread
Results 1 to 10 of 10

Thread: Video Tearing in game this am

  1. #1
    Shadowlander
    Join Date
    Feb 2011
    Posts
    32

    Default Video Tearing in game this am

    I bought a new laptop a couple months ago to play on while I am out of town. I have played the last five betas on this computer and this monring I had a problem ....

    The video was tearing across the screen in the Black Garden Warfront and in Meridian.

    The card is ATi Radeon 6550 mobility.

    No video problems in other games or programs.

    Did anyone else have a problem? Did the most recent update have any changes that may have caused this?

    I updated the drivers this am and the problem persists
    Punctuation SAVES LIVES!!!
    let's eat grandma!
    Let's eat, Grandma!

    See?!?!?

  2. #2
    Shadowlander
    Join Date
    Feb 2011
    Posts
    32

    Default

    Anyone else???
    Punctuation SAVES LIVES!!!
    let's eat grandma!
    Let's eat, Grandma!

    See?!?!?

  3. #3
    Soulwalker
    Join Date
    Feb 2011
    Posts
    6

    Default

    try updating your drivers and enabling vertical sync one of those two should work

  4. #4
    Shadowlander
    Join Date
    Feb 2011
    Posts
    32

    Default

    Quote Originally Posted by Delfias View Post
    try updating your drivers and enabling vertical sync one of those two should work

    Thanks, I tried both of them
    Punctuation SAVES LIVES!!!
    let's eat grandma!
    Let's eat, Grandma!

    See?!?!?

  5. #5
    Soulwalker
    Join Date
    Feb 2011
    Posts
    3

    Default

    Enabling vertical sync will fix it.

  6. #6
    Soulwalker
    Join Date
    Feb 2011
    Posts
    6

    Default

    are u opening it through steam? and try killing the ati catalyst control center
    Last edited by Delfias; 02-21-2011 at 11:10 AM.

  7. #7
    Rift Disciple
    Join Date
    Jan 2011
    Posts
    143

    Default

    Enable Vsync.


    Normally, Vysnc prevents the GPU from drawing more frames than you display is capable of displaying. (Most commonly these days 60)

    When you exceed that refresh rate, the card is drawing more than is possible to display and Image tearing occurs. Because many frames are being dropped.
    This is why those who brag about 125FPS etc, arent really getting it. The card is drawing it, yes, but It just ends up dropping all those extra frames because its physically impossible to display them.


    But, for some reason, there are some games that are not exceeding the refresh and still show image tearing, even at say 30ish FPS.
    RIFT is one of them. At least I notice it, and its annoying.

    Vsync will fix it for you though.
    Last edited by CenturyChild; 02-21-2011 at 11:20 AM.
    System Specs:
    MOBO: DFI DK x48
    CPU/RAM: Intel Q9650 @ 3.6 -- 8GB G-Skill Pi 1066 (4x2GB)
    Audio: X-Fi Xtreme Gamer (5.1 Speaker setup)
    GPU: Sapphire HD4890 Toxic
    Power: Corsair 650W PSU
    Case: Antec 900
    HDs: Intel 40GB SSDx2 -- 1TB & 640GB WD Black Ed.Spinners
    Display: LG-2453 @ 1920x1080

  8. #8
    Shadowlander
    Join Date
    Feb 2011
    Posts
    32

    Default

    I tried it in rift's interface area. Does anyone know if I can do it in ATI's catalyst center?
    Punctuation SAVES LIVES!!!
    let's eat grandma!
    Let's eat, Grandma!

    See?!?!?

  9. #9
    Rift Disciple
    Join Date
    Jan 2011
    Posts
    143

    Default

    Yes you can.
    Right Click your ATI Catalyst in the taskbar.

    Expand the menu for the first ATI Radeon, and then expand the menu for 3D settings.
    The options that says: "Wait for Vertical Refresh" set to always ON.
    You may wish to Enable Tripple Buffering as well.

    Alternatively, Open CCC and go to 3D settings. In the "ALL" tab, look for the same options.
    Last edited by CenturyChild; 02-21-2011 at 11:24 AM.
    System Specs:
    MOBO: DFI DK x48
    CPU/RAM: Intel Q9650 @ 3.6 -- 8GB G-Skill Pi 1066 (4x2GB)
    Audio: X-Fi Xtreme Gamer (5.1 Speaker setup)
    GPU: Sapphire HD4890 Toxic
    Power: Corsair 650W PSU
    Case: Antec 900
    HDs: Intel 40GB SSDx2 -- 1TB & 640GB WD Black Ed.Spinners
    Display: LG-2453 @ 1920x1080

  10. #10
    Shadowlander
    Join Date
    Feb 2011
    Posts
    32

    Default

    Quote Originally Posted by CenturyChild View Post
    Yes you can.
    Right Click your ATI Catalyst in the taskbar.

    Expand the menu for the first ATI Radeon, and then expand the menu for 3D settings.
    The options that says: "Wait for Vertical Refresh" set to always ON.
    You may wish to Enable Tripple Buffering as well.

    Alternatively, Open CCC and go to 3D settings. In the "ALL" tab, look for the same options.
    Thank you very much
    Punctuation SAVES LIVES!!!
    let's eat grandma!
    Let's eat, Grandma!

    See?!?!?

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts