+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 18
Like Tree2Likes

Thread: New Patch Problems

  1. #1
    Soulwalker
    Join Date
    Oct 2010
    Posts
    11

    Default New Patch Problems

    Hey guys. I run Rift through the Steam client. I tried to log in and pop up came up and said that I needed to patch the client. Fine, I load up the patcher.. No update button popped up. Right clicked the Rift thingie in the upper left hand corner and clicked on Update. Nothing.

    I tried going into the Rift folder itself and open Rift up. It updated there, but then proceeded to download 17 gigs worth of data.

    Any idea how to get the Steam thingie updated? Thanks.
    Meow.

  2. #2
    Shadowlander
    Join Date
    Jul 2018
    Posts
    34

    Default

    It's not Steam related. This happened during an earlier update as well. Someone at Gamigo forgot to set the NA clients to update to the latest patch, so even thought the shards are up, we can't get to them.

  3. #3
    Soulwalker
    Join Date
    Sep 2018
    Posts
    4

    Default Having the same issue

    Same issue.

  4. #4
    Soulwalker
    Join Date
    Jul 2016
    Posts
    6

    Default same here

    apparently new devs don't check their work

  5. #5
    Soulwalker
    Join Date
    Feb 2011
    Location
    Canada
    Posts
    11

    Default

    same problem I login in Europe patched it, going to North America I can't patch and I can't run it old patch!

  6. #6
    Soulwalker
    Join Date
    May 2011
    Posts
    16

    Default Have you seen your Rift today?

    So......It this the normal. Every week we get a non announced (in-game) maintenance that always say "expected to be 90 minutes" along with the additional hour or two of "You may be playing the wrong version of this. Please hang up and try again so we can tell you the same thing over and over?"

    I'm just curious is all. I sometimes like to budget my time accordingly without writing off a whole day of Rift.

  7. #7
    Soulwalker
    Join Date
    Jan 2019
    Posts
    1

    Default no patch available yet

    cannot load new patch

  8. #8
    Plane Walker ArcticGypsy's Avatar
    Join Date
    Jan 2014
    Posts
    405

    Default

    Same...

    - No update available in the Glyph client,

    - On hitting play get error
    "You are not running the correct version of the game" plz exit and run the patcher again"

    While I appreciate the work the skeliton staff is trying to do. Maybe spend a day with basic procedures might help things run smoothly.

    Get that Shutdown procedure fixed so there is in game warning again
    Get the patch procedure down.
    ( do the fixes, create a patch, apply said patch, make the update available, bring servers up)

  9. #9
    Soulwalker
    Join Date
    Dec 2010
    Posts
    6

    Default no patch

    no patch to install

  10. #10
    Rift Disciple
    Join Date
    Oct 2014
    Posts
    158

    Thumbs down

    EU doesn't get an update either.

    New Patch Problems-rift_version_mismatch.png

    Version mismatch ... "Update" doesn't act, "Repair" checked 25 GB and did not find outdated files.

  11. #11
    Soulwalker
    Join Date
    Jan 2019
    Posts
    2

    Default Same Problem

    When I try to run the game, Client runs but show message box that contains " You are not running the correct version of the game. Please exot and run the patcher again. A new update may be on its way!"

    I used the Patcher and Repair too but it doesn't works.

    Help me. Thanks
    Attached Thumbnails Attached Thumbnails New Patch Problems-riftbug.png  

  12. #12
    Plane Walker ArcticGypsy's Avatar
    Join Date
    Jan 2014
    Posts
    405

    Default

    Quote Originally Posted by LigH View Post
    EU doesn't get an update either.

    "Repair" checked 25 GB and did not find outdated files.
    Thanks for posting that....was thinking of running a repair as well. Saved me the time.

  13. #13
    Telaran
    Join Date
    Oct 2017
    Posts
    97

    Default

    yep, keeps telling me I'm running an incorrect version of the game. Exit and run the patcher again. There is no patch/update button for me on NA servers.
    You can't have everything..Where would you put it?

  14. #14
    Shadowlander Massiveaaron's Avatar
    Join Date
    May 2011
    Posts
    40

    Default Irritating

    What is really irritating is when I switch from NA to EU or back to NA in the drop down in the client, for a brief flash the big play button says UPDATE but then goes back to a play button. It's like a millisecond though so not much I can do with it.
    Coming back to RIFT and would like to find a decent guild.

  15. #15
    Soulwalker
    Join Date
    Jan 2019
    Posts
    1

    Default Same Issue

    Quote Originally Posted by Daytona View Post
    When I try to run the game, Client runs but show message box that contains " You are not running the correct version of the game. Please exot and run the patcher again. A new update may be on its way!"

    I used the Patcher and Repair too but it doesn't works.

    Help me. Thanks
    Glyph will not patch me into game on NA, Rift Live or Prime. Are servers back up?

+ Reply to Thread
Page 1 of 2 1 2 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts