+ Reply to Thread
Results 1 to 9 of 9

Thread: My Only Two Complaints about Storm Legion

  1. #1
    RIFT Guide Writer intrinsc's Avatar
    Join Date
    Feb 2011
    Location
    Warminster, PA
    Posts
    5,957

    Default My Only Two Complaints about Storm Legion

    After playing for several hours on my days off, I seem to be getting odd textures on rocks which makes them disappear. The more I play the worse it gets. Sometimes, it gets to the point of unaplayability because of popping in and out. Client restart does not fix this issue.

    The second issue is how you have to work so much harder for Qajiri rep. You have to travel more, fight through more trash, more less rep. Please, balance this rep to be on par with Necropolis Caretakers and Eternal City rep.

    Otherwise, I am very pleased as a customer with the product I've invested in and look forward to investing even more time and money into it as long as it stays quality.
    "I love being a father, but there are some things I miss: Silence, the absence of noise, one single moment undisturbed by the sounds of a childrens’ TV program called Doc McStuffins. There is no quiet anymore, there is only Doc McStuffins.
    — Ron Swanson, 2014

  2. #2
    Rift Disciple
    Join Date
    Jan 2011
    Posts
    146

    Default

    I have also noticed the texture thing. I have all the graphics options turned all the way up. Game runs great... Sill get great fps on invasion bosses.... But I do notice I have to restart my client every so often to fix the rocks and textures that start blinking at me.

  3. #3
    Champion Kraelith's Avatar
    Join Date
    Apr 2011
    Posts
    500

    Default

    Quote Originally Posted by ace1623 View Post
    I have also noticed the texture thing. I have all the graphics options turned all the way up. Game runs great... Sill get great fps on invasion bosses.... But I do notice I have to restart my client every so often to fix the rocks and textures that start blinking at me.
    same here after a few hours of playing I have to reset do to the blinking textures.

  4. #4
    Rift Chaser
    Join Date
    Feb 2011
    Posts
    335

    Default

    I agree there are odd texture issues.

    For example there was a well known problem going into Port Tempest from the ship, what happened is you fell though the world

    In the starter region (Tulon is the settlement) there is an area with a glitch with textures that enables you to go to places off map you could not normally get to. I have not identified where is is here but reported it to a GM.

    In City Core region there is a part buried Inn, that may be a mistake as the décor inside is clearly designed to be visible.

    A few other folks have also highlighted texture pointers

    But having said all this and in comparison with other MMO launches Storm has been fairly robust bar lag on the first day.......in GW2 for example there are still bugs even now

  5. #5
    Telaran Energon's Avatar
    Join Date
    Feb 2011
    Posts
    95

    Default

    There was a day when cliffs/mountains/rocks/hills were flickering and vanishing in (invisible but still solid), but a quick log out and log back in fixed it and I have not seen it since.

  6. #6
    Rift Disciple Decosse's Avatar
    Join Date
    May 2011
    Posts
    192

    Default

    I've had the flickering issue since even before SL hit, usually a relog fixes it for a while but it eventually comes back

    U guys running ATI cards by any chance? I do and just wondering if its particular to the card type or not?

    Otherwise, agree with OP, SL is just beyond awesome!

  7. #7
    Ascendant hardy83's Avatar
    Join Date
    Mar 2011
    Posts
    2,643

    Default

    Other people are getting this? Phew! Thought my video card was showing signs. lol

  8. #8
    Telaran Energon's Avatar
    Join Date
    Feb 2011
    Posts
    95

    Default

    I do have an ATI card and actually when I play Settlers 7 I have the same issue but just didn't link the two issues as the relog in Rift fixed the invisible world/flickering.

    Anyway when I play Settlers 7 the game starts with the camera sweeping over a forest etc well when I have don't have my card set to 'Use Application Settings' within the Catalyst Control Centre everything is made of glass. If I shut down Settlers and tick all the 'Use Application Settings' then Settlers runs fine.

    Just checked ebuyer and my card is - HIS HD 5850 iCooler 1GB GDDR5 Dual DVI HDMI Display Port Out PCI-E Graphics Card

    I bought it in September 2010 lol, think enough time has passed to justify an upgrade now me thinks
    Last edited by Energon; 11-22-2012 at 08:11 AM.

  9. #9
    Rift Master Ardwick's Avatar
    Join Date
    Jun 2011
    Posts
    646

    Default

    Quote Originally Posted by intrinsc View Post
    The second issue is how you have to work so much harder for Qajiri rep. You have to travel more, fight through more trash, more less rep. Please, balance this rep to be on par with Necropolis Caretakers and Eternal City rep.

    Otherwise, I am very pleased as a customer with the product I've invested in and look forward to investing even more time and money into it as long as it stays quality.
    Rumor has it that you can only go up to honored at the moment and that when dendrome opens up, there'll be dailies, etc there to get you the rest of the way.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts