Closed Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 16

Thread: black screen after pressing play button

  1. #1
    Rift Disciple
    Join Date
    Jan 2011
    Posts
    162

    Default black screen after pressing play button

    Hello, Ive sucessfully patched the game and when I press the Play button a black screen appears over the window task bar. No video or menu appears, no error mensagge appears, just a black screen and the windows 7 taskbar.
    The following processes of Rift are loaded while the black screen is on loading something:
    Code:
    rift.exe
    rifterrorhandler.exe
    This is my system information:
    Code:
    - Windows 7 Ultimate 32 bits. (With all patches).
    - 4GB RAM DDR 3 1333Mhz
    - AMD Athlon 640 X4
    - Gigabyte 890XA motheboard
    - ATI ASUS Radeon 4890
    - Directx 11 and Directx9 both installed and running perfectly.

    Ive tried the following but still no success:
    - Tested downgrading ATI driver from version 10.12 to 10.10 (Ive never installed CCC, only driver).
    - Tested uninstalling the game and reinstalling to folder c:\rift (installed directx9 too).
    - Tested using CCleaner, AtfCleaner, registry cleaner...
    - Tested running the game/files with full rights to all users, editing the files and running all of them as an Administrator.
    - Tested uninstalling Comodo Firewall
    - Tested running the game in windows XP compatibility mode.

    None of the above steps helped me, I still get the black screen with the cursor loading and nothing happens.

    help is really appretiated, thanks.
    Attached Thumbnails Attached Thumbnails black screen after pressing play button-rift_black_screen.jpg   black screen after pressing play button-processes.jpg  
    Attached Images  
    Attached Files
    Last edited by Spacesoul; 01-23-2011 at 02:27 PM. Reason: atached screenshoots, system info, and processes loaded

  2. #2
    Rift Disciple
    Join Date
    Dec 2010
    Posts
    149

    Default

    wait till there are servers up and try again?

  3. #3
    Rift Disciple
    Join Date
    Jan 2011
    Posts
    151

    Default

    Quote Originally Posted by Spacesoul View Post
    Hello, Ive sucessfully patched the game and when I press the Play button a black screen appears over the window task bar. No video or menu appears, no error mensagge appears, just a black screen and the windows 7 taskbar.
    The following processes of Rift are loaded while the black screen is on loading something:
    Code:
    rift.exe
    rifterrorhandler.exe
    This is my system information:
    Code:
    - Windows 7 Ultimate 32 bits. (With all patches).
    - 4GB RAM DDR 3 1333Mhz
    - AMD Athlon 640 X4
    - Gigabyte 890XA motheboard
    - ATI ASUS Radeon 4890
    - Directx 11 and Directx9 both installed and running perfectly.

    Ive tried the following but still no success:
    - Tested downgrading ATI driver from version 10.12 to 10.10 (Ive never installed CCC, only driver).
    - Tested uninstalling the game and reinstalling to folder c:\rift (installed directx9 too).
    - Tested using CCleaner, AtfCleaner, registry cleaner...
    - Tested running the game/files with full rights to all users, editing the files and running all of them as an Administrator.
    - Tested uninstalling Comodo Firewall
    - Tested running the game in windows XP compatibility mode.

    None of the above steps helped me, I still get the black screen with the cursor loading and nothing happens.

    help is really appretiated, thanks.
    have you tried going into the tech support section of the beta forums located here , http://forums.riftgame.com/forumdisp...chnical-Issues

    I had some problems when I first loaded the game last beta and the stickies there and people there were very helpful
    "Heaven won't take me and Hell's afraid I'll take over"

    Akirrah Auslander, 80 Druid , Everquest, Erollisi Marr 1999-2008
    Kaneda, 80 Guardian, Age of Conan, Set(Dagoth), 2008 - 2010

  4. #4
    Rift Disciple
    Join Date
    Jan 2011
    Posts
    162

    Default

    thanks gonna post it there

  5. #5
    Soulwalker Blackdragun's Avatar
    Join Date
    Jan 2011
    Location
    Pittsburgh, PA
    Posts
    5

    Default

    You can also check your event log to see if any errors w/ codes are produced to assist in troubleshooting the problem.

  6. #6
    General of Telara Absolutez's Avatar
    Join Date
    Dec 2010
    Location
    Telara
    Posts
    914

    Default

    Quote Originally Posted by Spacesoul View Post
    Hello, Ive sucessfully patched the game and when I press the Play button a black screen appears over the window task bar. No video or menu appears, no error mensagge appears, just a black screen and the windows 7 taskbar.
    The following processes of Rift are loaded while the black screen is on loading something:
    Code:
    rift.exe
    rifterrorhandler.exe
    This is my system information:
    Code:
    - Windows 7 Ultimate 32 bits. (With all patches).
    - 4GB RAM DDR 3 1333Mhz
    - AMD Athlon 640 X4
    - Gigabyte 890XA motheboard
    - ATI ASUS Radeon 4890
    - Directx 11 and Directx9 both installed and running perfectly.

    Ive tried the following but still no success:
    - Tested downgrading ATI driver from version 10.12 to 10.10 (Ive never installed CCC, only driver).
    - Tested uninstalling the game and reinstalling to folder c:\rift (installed directx9 too).
    - Tested using CCleaner, AtfCleaner, registry cleaner...
    - Tested running the game/files with full rights to all users, editing the files and running all of them as an Administrator.
    - Tested uninstalling Comodo Firewall
    - Tested running the game in windows XP compatibility mode.

    None of the above steps helped me, I still get the black screen with the cursor loading and nothing happens.

    help is really appretiated, thanks.
    Did you check your paging file and your virtual memory?
    "Live By The Sword, Die By The Sword"

  7. #7
    Rift Disciple
    Join Date
    Jan 2011
    Posts
    162

    Default

    yes its set to 3324mb.

  8. #8
    Telaran Sinner09's Avatar
    Join Date
    Dec 2010
    Location
    UK
    Posts
    86

    Default

    Have you tried running in window mode or use recovery on the client to see if any files corrupted?

  9. #9
    Rift Disciple
    Join Date
    Jan 2011
    Posts
    162

    Default

    yes, Ive tried in windowed mode, Ive tested with all settings disabled in rift.cfg and both resolutions 1680x1050 and 1280x1050 but no luck, Ive attached the screenshoot.
    Attached Thumbnails Attached Thumbnails black screen after pressing play button-rift_black_screen.jpg  

  10. #10
    Plane Walker Zolotaya's Avatar
    Join Date
    Jan 2011
    Posts
    433

    Default

    This is a basic question, but it is worth asking anyways: Are you running anything in the background that might interfere?

  11. #11
    Rift Disciple
    Join Date
    Jan 2011
    Posts
    162

    Default

    Just firefox, msn messenger and comodo firewall.
    Ive also tested uninstalling comodo and not running firefox and msn, but still keep getting it dunno why.

    attached the list of loaded processes.
    Code:
    Process	PID	CPU	Private Bytes	Working Set	Path	Description	Company Name
    System Idle Process	0	87.05	0 K	24 K			
     Interrupts	n/a		0 K	0 K		Hardware Interrupts	
     DPCs	n/a	1.53	0 K	0 K		Deferred Procedure Calls	
     System	4		44 K	256 K			
      smss.exe	260		308 K	796 K	C:\Windows\System32\smss.exe	Administrador de sesión de Windows	Microsoft Corporation
    csrss.exe	372		1.288 K	3.132 K	C:\Windows\System32\csrss.exe	Proceso en tiempo de ejecución del cliente-servidor	Microsoft Corporation
    wininit.exe	444		1.556 K	4.268 K	C:\Windows\System32\wininit.exe	Aplicación de inicio de Windows	Microsoft Corporation
     services.exe	496		6.068 K	12.048 K	C:\Windows\System32\services.exe	Aplicación de servicios y controlador	Microsoft Corporation
      svchost.exe	684		3.604 K	7.620 K	C:\Windows\System32\svchost.exe	Proceso host para los servicios de Windows	Microsoft Corporation
       WmiPrvSE.exe	3908		2.652 K	5.600 K	C:\Windows\System32\wbem\WmiPrvSE.exe	WMI Provider Host	Microsoft Corporation
      svchost.exe	768		5.444 K	8.388 K	C:\Windows\System32\svchost.exe	Proceso host para los servicios de Windows	Microsoft Corporation
      cmdagent.exe	896		29.444 K	7.200 K	F:\w7_programs\firewall\comodo\COMODO\COMODO Internet Security\cmdagent.exe	COMODO Internet Security	COMODO
      svchost.exe	932		10.036 K	11.936 K	C:\Windows\System32\svchost.exe	Proceso host para los servicios de Windows	Microsoft Corporation
      svchost.exe	976		15.596 K	15.956 K	C:\Windows\System32\svchost.exe	Proceso host para los servicios de Windows	Microsoft Corporation
      svchost.exe	1012		4.792 K	10.956 K	C:\Windows\System32\svchost.exe	Proceso host para los servicios de Windows	Microsoft Corporation
       WUDFHost.exe	3016		3.992 K	7.648 K	C:\Windows\System32\WUDFHost.exe	Windows Driver Foundation - proceso host del marco de controlador de modo usuario	Microsoft Corporation
      svchost.exe	1056		17.596 K	27.468 K	C:\Windows\System32\svchost.exe	Proceso host para los servicios de Windows	Microsoft Corporation
      svchost.exe	1220		8.016 K	13.360 K	C:\Windows\System32\svchost.exe	Proceso host para los servicios de Windows	Microsoft Corporation
      spoolsv.exe	1548		7.788 K	13.232 K	C:\Windows\System32\spoolsv.exe	Aplicación de subsistema de cola	Microsoft Corporation
      svchost.exe	1580		6.932 K	7.124 K	C:\Windows\System32\svchost.exe	Proceso host para los servicios de Windows	Microsoft Corporation
      taskhost.exe	1844		3.260 K	7.060 K	C:\Windows\System32\taskhost.exe	Proceso de host para tareas de Windows	Microsoft Corporation
      MDM.EXE	204		1.804 K	4.600 K	C:\Program Files\Common Files\Microsoft Shared\VS7DEBUG\MDM.EXE	Machine Debug Manager	Microsoft Corporation
      mysqld.exe	392		93.020 K	26.560 K	F:\w7_programs\mysql\mysql_5.5.8\bin\mysqld.exe		
      svchost.exe	1692		4.016 K	6.900 K	C:\Windows\System32\svchost.exe	Proceso host para los servicios de Windows	Microsoft Corporation
      svchost.exe	2980		7.228 K	12.404 K	C:\Windows\System32\svchost.exe	Proceso host para los servicios de Windows	Microsoft Corporation
      svchost.exe	3228		9.936 K	11.736 K	C:\Windows\System32\svchost.exe	Proceso host para los servicios de Windows	Microsoft Corporation
      sppsvc.exe	3692		5.428 K	7.872 K	C:\Windows\System32\sppsvc.exe	Servicio de plataforma de protección de software de Microsoft	Microsoft Corporation
     lsass.exe	504	0.38	3.952 K	9.448 K	C:\Windows\System32\lsass.exe	Local Security Authority Process	Microsoft Corporation
     lsm.exe	512		1.980 K	4.268 K	C:\Windows\System32\lsm.exe	Servicio de administrador de sesión local	Microsoft Corporation
    csrss.exe	452	1.92	16.648 K	12.920 K	C:\Windows\System32\csrss.exe	Proceso en tiempo de ejecución del cliente-servidor	Microsoft Corporation
    winlogon.exe	624		2.236 K	5.496 K	C:\Windows\System32\winlogon.exe	Aplicación de inicio de sesión de Windows	Microsoft Corporation
    explorer.exe	1808	0.77	25.704 K	40.244 K	C:\Windows\explorer.exe	Explorador de Windows	Microsoft Corporation
     cfp.exe	596		22.808 K	4.652 K	F:\w7_programs\firewall\comodo\COMODO\COMODO Internet Security\cfp.exe	COMODO Internet Security	COMODO
     jusched.exe	680		1.640 K	4.592 K	C:\Program Files\Common Files\Java\Java Update\jusched.exe	Java(TM) Update Scheduler	Sun Microsystems, Inc.
     msnmsgr.exe	1264		23.376 K	13.928 K	F:\w7_programs\Windows Live\Messenger\msnmsgr.exe	Windows Live Messenger	Microsoft Corporation
     firefox.exe	2660	0.38	80.248 K	97.960 K	F:\w7_programs\firefox\firefox.exe	Firefox	Mozilla Corporation
      plugin-container.exe	2044		23.224 K	33.016 K	F:\w7_programs\firefox\plugin-container.exe	Plugin Container for Firefox	Mozilla Corporation
     procexp.exe	2920	7.67	22.916 K	37.588 K	F:\w7_programs\process\procexp.exe	Sysinternals Process Explorer	Sysinternals - www.sysinternals.com
    Attached Thumbnails Attached Thumbnails black screen after pressing play button-processes.jpg  

  12. #12
    Soulwalker
    Join Date
    Jan 2011
    Posts
    1

    Default

    I have same problem.
    Windows 7 too and reinstalled DirectX.
    But NVidia card.
    Also rift.cfg.lnk links to "%APPDATA%\Trion Worlds\Rift\rift.cfg" but there is no such file.
    Last edited by KByte; 01-24-2011 at 02:56 PM.

  13. #13
    Rift Disciple
    Join Date
    Jan 2011
    Posts
    162

    Default

    its solved:

    -----------SOLVED--------------
    ----SOLVED---

    I saw that for some reason, Windows Update was not working, I did a netsh winsock reset and NO MORE BLACK SCREEN, now Ive seen the video and Im waiting for shard list (I suppose they are the servers).


    C:\Windows\System32>netsh winsock reset

    El catálogo Winsock se restableció correctamente.
    Debe reiniciar el equipo para completar el restablecimiento.



    Probably the issue is that, before the video is loading, the game is checking some registry entries and dns records, and trying to contact rift servers, if it cant reach them it just hangs without giving a message and loops in an end loop.

    ----

    a moderator please lock or delete this topic since I duplicate it, sorry.

    the main thread is at the technical support forum, now solved:
    http://forums.riftgame.com/showthrea...-game&p=575583

  14. #14
    Soulwalker RoJackal's Avatar
    Join Date
    Feb 2011
    Location
    Bucharest - Romania
    Posts
    9

    Default

    Quote Originally Posted by Spacesoul View Post
    its solved:

    -----------SOLVED--------------
    ----SOLVED---

    I saw that for some reason, Windows Update was not working, I did a netsh winsock reset and NO MORE BLACK SCREEN, now Ive seen the video and Im waiting for shard list (I suppose they are the servers).

    [B]
    C:\Windows\System32>netsh winsock reset
    This worked for me and also had to uninstall Widecap (I used Widecap for Wow tunneling through socks proxy)

  15. #15
    Soulwalker Resser's Avatar
    Join Date
    Feb 2011
    Posts
    22

    Default

    You sir are a Genius thanks i got past that spot

Closed Thread
Page 1 of 2 1 2 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts