+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 29

Thread: I have a mount... on my head

  1. #1
    Soulwalker
    Join Date
    Feb 2011
    Posts
    3

    Default I have a mount... on my head


    WTF?
    Last edited by villajon; 03-04-2011 at 09:48 AM.

  2. #2
    Shield of Telara
    Join Date
    Feb 2011
    Location
    Toronto
    Posts
    741

    Default

    Don't worry, that's completely normal.
    Hunbun - Female Dwarf Cleric - Faemist
    Missy - Female Kelari Warrior - Faemist
    Pilgrim - Male Mathosian Mage - Faemist

  3. #3
    Shadowlander Rhicard's Avatar
    Join Date
    Nov 2010
    Posts
    27

    Default

    Quote Originally Posted by Hunbun View Post
    Don't worry, that's completely normal.
    Ummm no,I have the same problem...what`s the fix for this please,I tried everything....

  4. #4
    Shadowlander Rhicard's Avatar
    Join Date
    Nov 2010
    Posts
    27

    Default

    Anyone? lots of people are getting this....

  5. #5
    Ascendant Rawne's Avatar
    Join Date
    Jan 2011
    Location
    UK
    Posts
    1,771

    Default

    Does that to me too sometimes.

    If I click on an artifact when i'm mounted or anything else that should dismount it just puts me kind of inside my mount.

  6. #6
    Shadowlander Rhicard's Avatar
    Join Date
    Nov 2010
    Posts
    27

    Default

    Quote Originally Posted by Rawne View Post
    Does that to me too sometimes.

    If I click on an artifact when i'm mounted or anything else that should dismount it just puts me kind of inside my mount.
    This is due to the removal of the Mount if you didnt get the CE though,if you where on it when you logged out before the patch,it`s on top of you now...even tried going into fox mode,it dissapears then but comes back after...

  7. #7
    Soulwalker
    Join Date
    Feb 2011
    Posts
    13

    Default O...m...g

    How much for the Flintstones mount?!!?!?

  8. #8
    Plane Touched Rajani Isa's Avatar
    Join Date
    Jan 2011
    Posts
    227

    Default

    Quote Originally Posted by Rawne View Post
    Does that to me too sometimes.

    If I click on an artifact when i'm mounted or anything else that should dismount it just puts me kind of inside my mount.
    Cool hat

  9. #9
    Soulwalker
    Join Date
    Mar 2011
    Posts
    1

    Default

    Suffering the same problem (via normal account), I made reference to it in another thread somewhere around here.

    Doesn't seem possible to fix it manually >:

  10. #10
    Rift Chaser Helmholz's Avatar
    Join Date
    Feb 2011
    Posts
    321

    Default

    Have you tried uninstalling Rift and then reinstalling it? No, you probably have not. It's the first thing you should do short of a reboot before you run onto the forums crying about your client-side issues. Learn to computer.

  11. #11
    Ascendant Rawne's Avatar
    Join Date
    Jan 2011
    Location
    UK
    Posts
    1,771

    Default

    Quote Originally Posted by Rhicard View Post
    This is due to the removal of the Mount if you didnt get the CE though,if you where on it when you logged out before the patch,it`s on top of you now...even tried going into fox mode,it dissapears then but comes back after...
    For the record I did get the CE directly from Trion.

    And it's been doing it since day 1 of the headstart.

    If I do anything that should normally dismount me, it does dismount me but my turtle stays there ..... with me inside it.

    Looks like my turtle is giving birth to a Dwarf through it's belly button.

  12. #12
    Community Manager Elrar's Avatar
    Join Date
    Nov 2010
    Posts
    2,584

    Default

    Hey all,

    We're currently aware of the issue and working on a fix at the moment. We should have it resolved shortly - thanks for your patience and enjoy the temporary fashion statement!
    Last edited by Elrar; 03-04-2011 at 10:09 AM.

  13. #13
    Plane Touched
    Join Date
    Jan 2011
    Posts
    252

    Default

    Put shoe on head?


    War = My Right to kill you. Therefore I derive my right to enslave you from my right to kill you which is derived from War!

  14. #14
    Shield of Telara
    Join Date
    Feb 2011
    Location
    Toronto
    Posts
    741

    Default

    Quote Originally Posted by Rhicard View Post
    Ummm no,I have the same problem...what`s the fix for this please,I tried everything....
    I was being sarcastic. ._.
    Hunbun - Female Dwarf Cleric - Faemist
    Missy - Female Kelari Warrior - Faemist
    Pilgrim - Male Mathosian Mage - Faemist

  15. #15
    Rift Chaser
    Join Date
    Feb 2011
    Posts
    323

    Default

    Quote Originally Posted by Rawne View Post
    Does that to me too sometimes.

    If I click on an artifact when i'm mounted or anything else that should dismount it just puts me kind of inside my mount.
    Then when u run again, it remounts u.
    Makes it so u dont have to unmount-remount.
    Nubs.

+ Reply to Thread
Page 1 of 2 1 2 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts