+ Reply to Thread
Results 1 to 4 of 4
Like Tree1Likes
  • 1 Post By Karsplat

Thread: BP and World Event quests going invisible

  1. #1
    Rift Disciple Karsplat's Avatar
    Join Date
    Oct 2013
    Posts
    183

    Default BP and World Event quests going invisible

    Hi,

    I've stumbled into a problem where none of the BP quests and none of the Summerfest quests except for the dailies are visible in my lists or quest tray. I have already reported this to customer service, and it's been mostly resolved to satisfaction, but I have found some more interesting bits regarding this that may help tracking and/or resolving the issue.

    I will focus on the Summerfest quests in the details provided below. I hope this will help track down the issue. I'm happy to provide more details and/or screenshots if needed.

    The issue
    I picked up the yearly Summerfest meta-quests, the ones that reward bracelets, on day 1 of Summerfest, and none of them appeared in my quest list or quest tray, nor did they create markers on the map.
    I shrugged this off at first, and went to the quest givers in the zones to pick them up and progress them. This worked fine, and the meta-quests progressed and eventually completed accordingly. So all in all, it was a bit of an annoyance, but nothing prohibitive.
    It also implies that the quests are assigned to me, and active, but just not visible.

    Then I got to the Goboro Reef quest "Sausage Party", which required me to use a quest ability from the quest tray. But since I could not see any of the quests, I could not use the ability, and therefore not complete the quest.

    In phase II, 2 more quests have the same issue: "Summerfest Infestation" and "A Sticky Seacap Situation", both requiring the use of a quest ability.

    Step by step
    1. I pick up the meta-quest in Meridian/Tempest Bay/Margle Palace
    2. The quest does not show in my quest list, nor quest tray
    3. The quest is active, and will progress, complete and reward as usual
    4. I cannot interact with the quest: I can't abandon, use quest abilities, or interact in any other way, because they are not in my quest list.
    5. The quest giver will not re-issue the quest, because I already have it

    The quests that have this unwanted behavior are:
    1. The Great Planar Scavenger Hunt, Part 1 and Part 2
    2. The Great Mathosian Scavenger Hunt, Part 1 and Part 2
    3. The Great Empyrean Scavenger Hunt, Part 1 and Part 2
    4. Capture Them All
    5. All sub-quests for these 7 meta-quests

    Daily summerfest quests and all normal quests do not show such behavior and are working just fine.

    Additional observations
    • When my quest list is open when I pick up the quest, it will be added to the list and be visible, until I close the quest list.
    • When I open my quest list (with invisible quests) and I shard hop, the invisible quests become visible, until I close the quest list
    • In either of the above cases, if click the toggle behind these quests, it will not show in my quest tray, so quest abilities are still a no-no. I can abandon the quests though.
    • This happens to my main character (Karsplat@Wolfsbane) only. Other characters on the same shard, other shards, or other accounts don't have this issue.

  2. #2
    Shadowlander
    Join Date
    May 2017
    Posts
    28

    Default Missing Quest Tracking

    Your issues were resolved? I tried repeatedly to get help and my ticket received no response at all. Caduto helped provide additional coordinates, but that's the only help I got. Interestingly this only impacted my main rogue and not my alts for Summerfest.

    Even my world event banner disappeared, but I was able to reset an option to get that back, but the quest tracker was disabled and that made completing Hunt1 and Hunt2 very difficult. My concern is that this is permanent and my rogue won't be able to do world event quests now.

    The lack of support has completely turned me off of Rift. I log in to do a few dailies, but I don't want to put effort into a game that has no support.

  3. #3
    Ascendant Aranka's Avatar
    Join Date
    Feb 2011
    Posts
    1,512

    Default

    late reply, sorry for that.. but did you check the quest log, if you have all the different types of quests selected?

  4. #4
    Shadowlander
    Join Date
    May 2017
    Posts
    28

    Default Follow Up

    So today, an hour after the event closed, I received a reply to either my original ticket or my follow up response.

    I was instructed to disable add-ons, close the game, launch Glyph, use the "repair" utility and respond "yes" to file recovery, then re-launch the game. If I'm still around I may try this for the next world event. They did tell me my Part 2/Kingsward Challenge was incomplete so I lost a bracelet and a basket.

    Thanks again to Caduto for all the coordinates and my stellar shadow alts for providing coordinates as well.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts