+ Reply to Thread
Results 1 to 3 of 3

Thread: Are we down again or...

  1. #1
    Soulwalker
    Join Date
    Jul 2019
    Posts
    11

    Default Are we down again or...

    I tried logging in, in Tempest Bay. Lasted less than a minute and booted. After 6 times I tried a toon in another zone. Stillmore I believe it's called. Same thing. Rebooted my laptop and now I can't even get to character selection. My son has had this issue for a couple weeks now while I continue to play so I'm not sure if it's me or you this time. Thanks.

  2. #2
    Rift Chaser Ambrodel's Avatar
    Join Date
    Jan 2011
    Posts
    324

    Default

    Quote Originally Posted by Snowwolff View Post
    I'm not sure if it's me or you this time.
    I just logged in, no issues and as fast as it's always been. Maybe it would help to pinpoint issues if you mentioned which region you're in. EU can be fine while NA is FUBAR, or the other way around.

  3. #3
    Soulwalker
    Join Date
    Jul 2019
    Posts
    11

    Default

    Oh DUH sorry, Tried both EU and NA servers and can't get in. Says login failed, no number or anything. Thanks again!

    Editing rather than adding another post. Repair did nothing, reinstalled and got in. I played last night just fine. I don't get it but oh well.
    Last edited by Snowwolff; 08-23-2019 at 03:00 AM.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts