+ Reply to Thread
Results 1 to 5 of 5

Thread: latency - no way

  1. #1
    Soulwalker
    Join Date
    May 2011
    Posts
    7

    Default latency - no way

    So I submitted a ticket on this issue:
    I have had this issue for several days. Am at level 66 and when I hit my combat buttons they don't work for about 30-35 seconds. Enemies are not rezzing for minutes. If I get the slide that shows my combat working and hit another button I get the message Another Ability Prepping.
    This makes the game impossible to play.
    I have relogged, I have exited and restarted game. Nothing is changing. I checked advanced video settings and checked they were up.
    Only other thing I have noticed is the first loading circle only gets to 25% before the start screen pops up. I usually watch it circle to 100%upload. I transferred to a different shard... same issue.
    Checked my upload and download speeds, they are all good. ( Download = 575.22 and upload = 434.98). NPCs are not loading and ability prepping messages coming down on me fast and furious
    . So I doubt it is lag, plus other different games eg: guild wars are running fine.
    But the letter I get from Rift says "We appreciate you taking the time to submit this feedback for RIFT, however although the customer service department is here to assist with in-game issues, we unfortunately are unable to fix technical issues caused by latency."
    If they are referring to my ping, it's 1. (Go figure) I am beyond upset. I am not getting support from Glyph or Trion Worlds. How do I deal with this? Can anyone help me?
    Cavishae
    Last edited by Kavisha; 08-05-2019 at 01:22 AM.

  2. #2
    Soulwalker
    Join Date
    Dec 2018
    Posts
    24

    Default

    I didn't read anywhere that you ran a repair or did I miss that? (right click Rift on the log-in screen). Here is the Troubleshooting link, maybe you know it but will link it anyways.

    https://support.gamigo.com/hc/en-us/...roubleshooting

  3. #3
    Champion Shas's Avatar
    Join Date
    Apr 2012
    Posts
    543

    Default

    Since you are playing other online games. I once had a crippling issuee with swtor leaving a 32bit progamm after uninstalling, called Bitraider (Background game downloader), which buged out and took 98% of my bandwith.

    Chance there is something fking it up? (since it's somewhat connection related what you say)
    Last edited by Shas; 08-05-2019 at 08:02 AM.

    Hierosolyma | Katane | Azuren | Jeru | Syenn | Shas | Shaslol | Shastroll

  4. #4
    Plane Walker
    Join Date
    Jul 2014
    Posts
    416

    Default

    The reason you are having these issues is due to the move to gcp. It will take time to iron out the kinks, granted most of the kinks should have been dealt with before the merge. There's pretty much nothing you can do. Support can't do anything. Only the Engineers can do something about this.

    Also, Trion Worlds is no longer in business. So you will never get help from them again. You can, however, wait for the developer of Rift to get it's engineers to fix the issues.
    Last edited by Mrwidoes; 08-05-2019 at 09:26 AM.
    In the wise words of my professor.. Did you read?

  5. #5
    Soulwalker
    Join Date
    May 2011
    Posts
    7

    Default

    Thank you everyone for your help and suggestions. (Yes I did a repair). Damn might park Rift and find something else to put my time and energy into.

    You guys rock.

    Cheers

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts