+ Reply to Thread
Results 1 to 6 of 6
Like Tree2Likes
  • 1 Post By Goddessdavida
  • 1 Post By Aador

Thread: "Not running correct patch"?

  1. #1
    Soulwalker
    Join Date
    May 2016
    Posts
    5

    Default "Not running correct patch"?

    Attempting to log in, I get "You are not running the correct patch".

    Log out, log in again, still no patch.

    Is there a way to force a patch to update, or do I just sit here twiddling my thumbs and hope for the problem to go away?

  2. #2
    Rift Chaser Goddessdavida's Avatar
    Join Date
    May 2014
    Posts
    325

    Default

    IDK yet if this is the right solution. I went to the EU shards, I got the update button and downloaded everything. After that, all the shards are locked over there anyway. Back to the US side, it says update, which I presume would revert me to the "wrong" version again.

    I think all that is happening is that they are not yet done with maintenance, and someone forgot to post the new version on the US side. They asked for 2 hours, and that hasn't elapsed yet. Time will tell.

  3. #3
    Ascendant Aranka's Avatar
    Join Date
    Feb 2011
    Posts
    1,427

    Default

    they are currently still running the update ...

    It started 16:30 CET / 7:30 PST... and can last upto 2 hrs.

    They just don't let us update as fast as they used to in the past, which may be wise considering the issues lately

  4. #4
    Soulwalker
    Join Date
    Aug 2011
    Posts
    7

    Default

    Still got this error even after servers were up on 64 bit. Ran repair and it fixed it. Good luck

  5. #5
    Soulwalker
    Join Date
    May 2019
    Posts
    1

    Default Bug still happening

    As of 11:00 CT 5/29/19, I am still getting this bug. The patch notes say the game was patched early this morning, but I still cannot even access the patch. I've tried forcing the update and repairing through right clicking on the Rift tab of Glyph, I've tried switching to Europe server, updating there, then switching back to U.S. server and updating again, still getting the same error that I am not running the current version of the game and to look out for a patch on its way.

    I ran into this problem on the 22nd as well. I ended up uninstalling both Rift and Glyph and reinstalling them both. I do not want to do this every single time this game patches. Can something permanent be done to fix this?
    Thank you.

  6. #6
    Rift Disciple phoenix1957's Avatar
    Join Date
    Jan 2015
    Posts
    116

    Default

    Exactly the same error occurred a few weeks ago. So the same workaround as then.

    Charwyn@Brutwacht

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts