+ Reply to Thread
Results 1 to 8 of 8
Like Tree1Likes
  • 1 Post By Zornar

  Click here to go to the first Rift Team post in this thread.   Thread: Mismatch between NA and EU versions

  1. #1
    Rift Disciple
    Join Date
    Mar 2012
    Posts
    111

    Default Mismatch between NA and EU versions

    This Sunday seems to have created a mismatch between the NA and EU versions of the game. I have characters on both.

    When I change from NA to EU, it requires an Update. When I change back to NA, it again requires an Update. The link on both NA and EU says the patch was done for the same reason - "Fixed a bug which prevented the Celestial Slayer Club from successfully being upgraded."

  2. #2
    Soulwalker JadeCat's Avatar
    Join Date
    Jun 2015
    Posts
    18

    Default

    I am on NA only and I had to update.


    I Am and always will be a Murphy's Child....

  3. #3
    Rift Disciple
    Join Date
    Mar 2012
    Posts
    111

    Default

    Quote Originally Posted by JadeCat View Post
    I am on NA only and I had to update.
    Yes, but I have to update every time I switch from NA to EU and then update again when I switch back to NA. Every time. It's like the movie Ground Hog Day, stuck in a time loop of never ending updates.

  4. #4
    Soulwalker JadeCat's Avatar
    Join Date
    Jun 2015
    Posts
    18

    Default

    I wanted to try EU so I did and couldn't play it lagged so bad, When I switched back to NA I had to update looks like it's not just you.


    I Am and always will be a Murphy's Child....

  5. #5
    Rift Master
    Join Date
    Mar 2015
    Posts
    630

    Default

    It's everybody, and super annoying. +1 to fix plz

  6.   This is the last Rift Team post in this thread.   #6
    Rift Team Liluri's Avatar
    Join Date
    Nov 2018
    Posts
    29

    Default

    I have reported the issue but can you please confirm to me if the issue is still happening on your side?

  7. #7
    Soulwalker
    Join Date
    Jan 2019
    Posts
    1

    Default glyph

    i have the same issue 2 days now too. i have to update Glyph every time

  8. #8
    Rift Master
    Join Date
    Mar 2015
    Posts
    630

    Default

    This no longer occurs for me. Thank you for fixing it (if it is fixed and I didn't just get lucky today).

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts