+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 20

Thread: Really Terrible Framerates In CQ & Warfronts

  1. #1
    Shadowlander SubRock's Avatar
    Join Date
    Feb 2011
    Posts
    47

    Default Really Terrible Framerates In CQ & Warfronts

    When I zone into CQ, I'm usually rocking about 30 fps, but that declines steadily. By the time I'm in the zerg, my framerate is around 15fps. When the main battles occur my framerate drops to a mind numbing 2 - 4 fps.

    I'm running an above-average comp, set up for gaming.

    I have all shadows turned off and other settings down to low to try to maximize framerate. No luck.

    Is anyone else having problems with framerates in CQ, and even in WFs? Do I need to overhaul my computer or is this a common problem for others? Please advise.

  2. #2
    Ascendant Fujitasix's Avatar
    Join Date
    Feb 2011
    Posts
    3,416

    Default

    Have you turned off other player's hit effects?

    I've dipped down to near 10 FPS in the really huge zergs lately, but I attribute that to having 250+ players in a shoebox. Normal FPS is ~20-25 for a 80v80 if you're using the extractor tips to get your approximate player numbers.
    Currently playing Beermaid lvl 65 War

  3. #3
    Shadowlander SubRock's Avatar
    Join Date
    Feb 2011
    Posts
    47

    Default

    Yes, I've turned off other players effects, capes, shadows, everything I could think of.

    I run a comp I custom built for gaming. Core i7 980X processor, GeForce GTX 670 vid card, EVGA X-56 Classified mobo. I tried to spare no expense to create a great gaming rig, but I'm not getting expected framerates from Rift.

    This never used to be a problem before Storm Legion. It's really taking the fun out of CQ for me.

  4. #4
    Ascendant Violacea's Avatar
    Join Date
    May 2011
    Posts
    12,128

    Default

    Sounds like something weird is going on. I run a 2500k (4.4ghz) and GF570 - I just turn off Super Sampling and Shadows for stuff like CQ and get fairly good FPS. When it gets insanely bad I drop to around 10 - 14fps. It isn't uncommon to see my frame rate hit 50 - 100 throughout the course of a CQ though. Obvs 100 is when I am damn near alone.

    Installed anything recently for rift like add-ons? It just sounds like something is directly affecting the game that is a bit out of the ordinary.
    Last edited by Violacea; 02-15-2013 at 01:03 PM.
    New round up of some high rank matches
    Chun-Li*E.Honda*Evil Ryu
    Abel*Ibuki*Dhalsim
    Gouken*Zangief*Ryu

  5. #5
    Shadowlander SubRock's Avatar
    Join Date
    Feb 2011
    Posts
    47

    Default

    Yeah, that's what I was afraid of. Something specific to my machine. Guess I'm gonna have to run diagnostics on it and see if anything is amiss.

    Before SL, I ran the game in ultra mode and never had a problem.

    I'm bummed.

  6. #6
    Fia
    Fia is offline
    Champion of Telara Fia's Avatar
    Join Date
    Apr 2012
    Posts
    1,349

    Default

    Have the same problems, but I also have them in 20man raids, especially FT.

    Specs:
    i7-3770K@4,3GHz
    12GB RAM (Corsair Dominator)
    ASUS Sabertooth Z77
    Gainward Geforce GTX 670 Phantom
    Samsung 128GB SSD

    Many people have this problem though, you're not the only one. It's obviously not our PCs that are too weak, the RIFT engine is simply outdated as hell. Needs some serious updating, but I don't think we can hope for that anytime soon ... :V
    Last edited by Fia; 02-15-2013 at 01:47 PM.
    Fiia@Typhiria | Asthea@Hailol
    Cleric-Heal/Tank/DD | Lvl70

    Now with new Prime Content! -> http://youtube.com/astheatv


  7. #7
    Rift Disciple Verysneaky's Avatar
    Join Date
    Jul 2012
    Posts
    101

    Default

    Make sure the cpu option in rift cfg file is set to 0 value problem with this game is it does not take advantage of cpu cores. I found that overclocking my north bridge to 2700mhz helped a bit . And Sli is big dissapointment as well.
    Elitest@Seastone

  8. #8
    Telaran SuddleD's Avatar
    Join Date
    Dec 2010
    Location
    Bay Area, CA
    Posts
    76

    Default

    Seems about right. I have a similar setup, i7, GTX670, 32gb ram...but drops to 10-20 fps in CQ battles.

  9. #9
    Telaran Adegard's Avatar
    Join Date
    Feb 2012
    Posts
    86

    Default

    Quote Originally Posted by Violacea View Post
    Sounds like something weird is going on. I run a 2500k (4.4ghz) and GF570 - I just turn off Super Sampling and Shadows for stuff like CQ and get fairly good FPS. When it gets insanely bad I drop to around 10 - 14fps. It isn't uncommon to see my frame rate hit 50 - 100 throughout the course of a CQ though. Obvs 100 is when I am damn near alone.

    Installed anything recently for rift like add-ons? It just sounds like something is directly affecting the game that is a bit out of the ordinary.
    Finally someone who's having pretty much the same configuration as I do and who's getting the same results. Been getting bashed by some people any time I mentioned I'm running an I5 2500k @ 4.4Ghz with a gtx 560 Ti @ 950 Mhz and I'm being more than satisfied with the way the game runs, even in Conquest.
    Adegard □ Blightweald
    Pain is temporary, pride is forever

  10. #10
    Plane Walker
    Join Date
    Apr 2010
    Posts
    412

    Default

    Disabeling parser (super meter) worked wonders to me. Totally unplayable CQ turned fine for all time except 100+ zergs at prime time. And even then its mostly playable. My PC is almost 3 years old.

    ps. try same at volan if it lags
    I was born amidst the purple waterfalls.
    I was weak, yet not unblessed.
    Dead to the world. Alive for the journey. -Nightwish, Bless the Child

  11. #11
    Ascendant Fujitasix's Avatar
    Join Date
    Feb 2011
    Posts
    3,416

    Default

    Quote Originally Posted by Adegard View Post
    Finally someone who's having pretty much the same configuration as I do and who's getting the same results. Been getting bashed by some people any time I mentioned I'm running an I5 2500k @ 4.4Ghz with a gtx 560 Ti @ 950 Mhz and I'm being more than satisfied with the way the game runs, even in Conquest.
    I have basically the same setup, and I'm another one of those people getting good performance all the time. Rift seems to prefer Ivy > Sandy. The architecture is pretty similar from what I've read, doesn't make a lot of sense.
    Currently playing Beermaid lvl 65 War

  12. #12
    Champion of Telara Mire's Avatar
    Join Date
    May 2011
    Posts
    1,387

    Default

    Try disabling addons, especially supermeter

  13. #13
    Shadowlander SubRock's Avatar
    Join Date
    Feb 2011
    Posts
    47

    Default

    Could a hard drive be the root of the problem? I switched out the GTX 670 and replaced it with my old GTX 295... no change in performance, so it's not the video card.

    I've got a suspicion that I have a hard drive beginning to fail.

  14. #14
    Ascendant Misun's Avatar
    Join Date
    Feb 2011
    Location
    The Sticks
    Posts
    5,802

    Default

    Welcome to Rift, where large groups of people give you 3 fps.

    Enjoy!
    Pridy Bebe of Mobile Death Squad @Faeblight

    DYER the best unofficial Rift forum.

  15. #15
    Ascendant Fujitasix's Avatar
    Join Date
    Feb 2011
    Posts
    3,416

    Default

    Quote Originally Posted by Misun View Post
    Welcome to Any MMO, Ever! where large groups of people give you 3 fps.

    Enjoy!
    Fixed that for ya. Unless you'd like to show me some video evidence otherwise. We had 144 NF attacking the boss last night in CQ, and a lot of people had already left when the CQ tokens were awarded, so I'd have to wager the teams were probably 180-200.

    Show me some ~400 player combat within a 200m circumference that plays better than 10 FPS, and then we can call Rift's engine poorly optimized. GW2 fares no better, SWTOR choked and puked on 30 players - they had to shut down their "massive" PvP zone. Warhammer was a slideshow, WoW fared even worse when people converged on the doors in Wintergrasp - all with fewer players.

    I'm not trying to defend it or say it couldn't be better, but I'm being a realist with ~4GHz CPU threads (16? 32?) still bottlenecking the exponential telemetry of that many players in close enough proximity to require processor time.
    Currently playing Beermaid lvl 65 War

+ Reply to Thread
Page 1 of 2 1 2 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts