+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 29

Thread: Lord Greenscale bugs, WTF?

  1. #1
    Plane Touched
    Join Date
    Jun 2010
    Posts
    183

    Default Lord Greenscale bugs, WTF?

    So my guild has been 4/5 on GSB for a week or so, but the bugs on Lord Greenscale himself are truly horrendous. We've had the following happen:

    Four times tonight, we've killed the annihilator and got no bubble. I'm aware he can consume him, but that wasn't what happened as he received no heal. Four times, out of 13-14 attempts. That's a ridiculous percent to have the fight bug out and become unwinnable.

    Then, just now, we got him to 25%, we were in the bubble (and had everyone in the raid up). The bubble lasted longer than normal and then when it vanished he just reset for no reason.

    Are these both acknowledges problems? Because they're really ruining this fight for us. WTF is the point in content that is just a lottery?

    @#%#@@#%@#%@

    So angry.
    Last edited by Andykay; 05-24-2011 at 05:16 AM.

  2. #2
    Shield of Telara
    Join Date
    Sep 2010
    Posts
    750

    Default

    The first time the annihilator didn't spawn the bubble he was consumed by greenscale but the next 3 times there was no consume, the killing blow was done by a player.

    This is definitely an annoying bug, although having it reset at 25% is pretty bad too.

  3. #3
    Plane Touched
    Join Date
    Jun 2010
    Posts
    183

    Default

    Okay my bad, but point stands.

  4. #4
    Plane Touched
    Join Date
    Jun 2010
    Posts
    183

    Default

    Also I forgot to mention the plants not despawning after a wipe. That's a pretty irritating one as well.

  5. #5
    Soulwalker Maldek's Avatar
    Join Date
    Jan 2011
    Location
    Australia
    Posts
    12

    Default

    Definatley in need of repairs ASAP!!. The raid spends so much effort into carving its way through to Greenscale only to be subdued by shifty bugs like these, im mean seriously, WTF. And a random reset at 25%, WTF!!!!
    Id understand it more if it were the trivial areas of the game such as world mobs as such but not major boss fights, unacceptable. Plz Hotfix.


    Bump this thread peeps

  6. #6
    Sword of Telara GoldenArrow's Avatar
    Join Date
    Dec 2010
    Location
    Finland
    Posts
    745

    Default

    Only replies we are getting from devs are about character transfers.
    Seems like that's their only agenda at the moment. :s
    Last edited by GoldenArrow; 05-24-2011 at 06:38 AM.

  7. #7
    Plane Touched
    Join Date
    Jun 2010
    Posts
    183

    Default

    So the final boss of their premium endgame experience and also the final part of their longest and most epic quest chain is plagued with bugs and that's not a concern? =/

    We've wrapped up now, but we had six wipes to bugs from 15 attempts.

    Never been more frustrated at content than I am right now.

  8. #8
    Shield of Telara
    Join Date
    Sep 2010
    Posts
    750

    Default

    Anyone know if there is some kind of behavior that causes the bubble to not spawn after the Annihilator dies or is it just a random 'sorry you lose' event?

  9. #9
    Telaran
    Join Date
    Feb 2011
    Posts
    66

    Default

    Killing the small adds first, then the annihilator... seemed to work for us.
    Had no bubble several times when there was 1+ other add still alive when annihilator died.
    Last edited by DeXyre; 05-24-2011 at 11:57 PM.


  10. #10
    Rift Disciple Rustifer's Avatar
    Join Date
    Jan 2011
    Location
    Chicago, IL
    Posts
    98

    Default

    We had that happen to us. He also bugged by staying in the air for one entire 25% chunk of his health. It was good and bad. Bad for healers, good for dps, but we still wiped.

    Got our first kill last night.
    Rustifer -- Defiant Mage -- <Anarchy United>

    Posting your Entire MMO History is Lame.

  11. #11
    Rift Chaser Cybaster's Avatar
    Join Date
    Dec 2010
    Location
    Kinshasa
    Posts
    246

    Default

    This has been driving my guild nuts, as well. Got him down to 20%, nobody dead, flawlessly playing, and bam. No bubble, everybody dies, relics denied. We can't figure out what's doing this.

    I know for a fact that having all the little adds dead when the annihilator dies doesn't work. I've seen him fail to bubble in this scenario. It also seems to happen regardless of the positioning of the adds - we've seen this happen when they were killed off midfield, and it has happened when they were tanked and killed directly under him.

    The next thing we're going to try is yanking one add out, so that we can leave little one up for him to eat every time.

    "Crito, I owe a **** to Asclepius; will you remember to pay the debt? "
    SUPREME GRILLMASTER of The Enclave

  12. #12
    Prophet of Telara
    Join Date
    Feb 2011
    Posts
    1,028

    Default

    We focus the annihilator entirely, cleave off it. Normally 1 or 2 adds are still up by the time the bubbles spawns at which point we clear them up and proceed to pewpew the Iguana.
    Horrible Main Tank of --- <Zombie Goasts> - Shatterbone (US Guardian)
    Crappy Youtube Page: http://www.youtube.com/exphryl

  13. #13
    Shield of Telara
    Join Date
    Sep 2010
    Posts
    750

    Default

    We had Greenscale take off at 75%, stay in the air until 55% then finally land only to take off again at 50% as he's supposed to. Then when he took off at 25% he stayed in the air for ages then went to land and immediately reset.

    This fight is so frustrating!

    The worst though is the bubbles not spawning. Nothing seems to make a difference. Kill the annihilator first, no bubble. Kill the Annihilator last, no bubble. It's just a random 'you lose' bug it seems.

  14. #14
    RIFT Community Ambassador bluedot's Avatar
    Join Date
    Mar 2011
    Posts
    1,486

    Default

    Quote Originally Posted by sakkath View Post
    The worst though is the bubbles not spawning. Nothing seems to make a difference. Kill the annihilator first, no bubble. Kill the Annihilator last, no bubble. It's just a random 'you lose' bug it seems.
    We think we have narrowed it down to certain spots in the terrain. Like if he dies on a crevice or small bump he has a higher chance of not dropping the bubble.
    But its just a guess at this point.

  15. #15
    Soulwalker
    Join Date
    Jan 2011
    Posts
    12

    Default

    I remember a bug on Duke where the shamblers wouldn't spawn their cloud and I believe it was found to be caused by a pet getting the killing blow. It still happens to us rarely and I've seen the Annihilator bug as well, could be the same issue.
    Shifty < Hate >

+ Reply to Thread
Page 1 of 2 1 2 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts