+ Reply to Thread
Results 1 to 11 of 11
Like Tree6Likes
  • 1 Post By Feendish
  • 1 Post By Feendish
  • 1 Post By Teslachu
  • 1 Post By Agrona77
  • 1 Post By JaydedRIft
  • 1 Post By JaydedRIft

Thread: Questions about dimensions from a new player >.<

  1. #1
    Telaran Teslachu's Avatar
    Join Date
    Jun 2014
    Posts
    66

    Default Questions about dimensions from a new player >.<

    Does anyone know what causes a bug in the dimensions area that causes certain items you place (Like: Bonfire Fire, cooking fire, time of day, falling motes .... etc...) to not disappear like they should, once you are out of edit mode? I have been having this problem a lot lately. I also cant seem to get 2 new animated ones to work in my dimension either... I am only at 124/250 for my dimension. I hate to ask such questions, but I've only been playing for about a week and have put a lot of time into my dimension, so it is frustrating that it is not working properly. Thanks for any help! <3

    Edit: I forgot to add some additional information -- No I am not building outside of the wall/barrier. This is all being built within the dimension limits.
    Last edited by Teslachu; 06-29-2014 at 02:04 PM. Reason: adding more information

  2. #2
    RIFT Fan Site Operator Feendish's Avatar
    Join Date
    Mar 2013
    Posts
    3,035

    Default

    Quote Originally Posted by Teslachu View Post
    Does anyone know what causes a bug in the dimensions area that causes certain items you place (Like: Bonfire Fire, cooking fire, time of day, falling motes .... etc...) to not disappear like they should, once you are out of edit mode? I have been having this problem a lot lately. I also cant seem to get 2 new animated ones to work in my dimension either... I am only at 124/250 for my dimension. I hate to ask such questions, but I've only been playing for about a week and have put a lot of time into my dimension, so it is frustrating that it is not working properly. Thanks for any help! <3

    Edit: I forgot to add some additional information -- No I am not building outside of the wall/barrier. This is all being built within the dimension limits.
    No worries, we're here to help if we can.

    The little icons not disappearing when you exit edit mode is a known graphical glitch. To clear it, leave the dimension and return, and the icons should be gone with the effects still in place.

    As far as the animations go, make sure projected textures and spell detail are turned on to be able to see effects, and if that still doesn't work, look at submitting a ticket.
    Dimensions on Greybriar and Zaviel


    Baradara@Greybriar

  3. #3
    Telaran Teslachu's Avatar
    Join Date
    Jun 2014
    Posts
    66

    Default

    Quote Originally Posted by Feendish View Post
    No worries, we're here to help if we can.

    The little icons not disappearing when you exit edit mode is a known graphical glitch. To clear it, leave the dimension and return, and the icons should be gone with the effects still in place.

    As far as the animations go, make sure projected textures and spell detail are turned on to be able to see effects, and if that still doesn't work, look at submitting a ticket.
    Thing is I have tried to leave and re-enter. They are still all bugged out. Let me try and then upload a screen shot so you can see how annoying it is. XD

  4. #4
    Telaran Teslachu's Avatar
    Join Date
    Jun 2014
    Posts
    66

    Default

    ~~~ OH! This time they disappeared when I came back in. How odd. ~~ Projected textures and spell details? Not sure I understand. I picked up an intermitten blue lighting. All my other animated stuff seems to be working but not this one and I have graphics on high. :/


    Edit: Go figure that as I hit post, it decided to go off. XD ~ Thanks for the help!
    Last edited by Teslachu; 06-29-2014 at 02:14 PM.

  5. #5
    RIFT Fan Site Operator Feendish's Avatar
    Join Date
    Mar 2013
    Posts
    3,035

    Default

    Projected textures and spell details are in your settings.

    Settings>Video>Advanced video

    There's a check box for Projected Textures, and the spell detail is a slider bar. The lightning should be a spell detail, so if that's off or set very low, you probably won't be able to see it.

    As for the others still not turning off when you leave and return, I would definitely submit a ticket for that, because leaving should clear that.

    I totally get how irritating it is....

    Questions about dimensions from a new player >.<-2014-06-29_174233.jpg
    Dimensions on Greybriar and Zaviel


    Baradara@Greybriar

  6. #6
    Telaran Teslachu's Avatar
    Join Date
    Jun 2014
    Posts
    66

    Default

    Quote Originally Posted by Feendish View Post
    Projected textures and spell details are in your settings.

    Settings>Video>Advanced video

    There's a check box for Projected Textures, and the spell detail is a slider bar. The lightning should be a spell detail, so if that's off or set very low, you probably won't be able to see it.

    As for the others still not turning off when you leave and return, I would definitely submit a ticket for that, because leaving should clear that.

    I totally get how irritating it is....

    Attachment 18974

    Oh my. Well thank you again for all your help and I can see you do get it! I hope they fix it soon.

  7. #7
    Ascendant Agrona77's Avatar
    Join Date
    Dec 2010
    Location
    US
    Posts
    2,856

    Default

    Yea, I have graphic issues now and then where
    a. The icons for the special effects flicker in different colors
    b. The special effects, especially fire, won't show up.

    Often times, when it's that bad, my character also has green lips. I then have to pretty much restart my whole client, in order to get everything back to normal. LOL

    It was really bad in my Temple of the Abandoned dim. The fire wouldn't show up on a regular basis, nor did the lightning effects. Maybe that's why I now "abandoned" that dim. LOL Haven't visited that one in ages, but everything is still in place. Oh well...

    So yea, even with all the settings checked, your client can still bug out when it comes to special effects in dims. If it gets really bad, just restart your client and when you first enter your dimension, don't click on the dimension tools, and everything should appear as you want it to.

  8. #8
    Telaran Teslachu's Avatar
    Join Date
    Jun 2014
    Posts
    66

    Default

    Quote Originally Posted by Agrona77 View Post
    Yea, I have graphic issues now and then where
    a. The icons for the special effects flicker in different colors
    b. The special effects, especially fire, won't show up.

    Often times, when it's that bad, my character also has green lips. I then have to pretty much restart my whole client, in order to get everything back to normal. LOL

    It was really bad in my Temple of the Abandoned dim. The fire wouldn't show up on a regular basis, nor did the lightning effects. Maybe that's why I now "abandoned" that dim. LOL Haven't visited that one in ages, but everything is still in place. Oh well...

    So yea, even with all the settings checked, your client can still bug out when it comes to special effects in dims. If it gets really bad, just restart your client and when you first enter your dimension, don't click on the dimension tools, and everything should appear as you want it to.
    Well thank you so much for the advise. It is good to know its not just me. I wonder if anyone else is having the same crashing issue I have. Sometimes I place an item down, decide I dont like it in that area, so I hit #4 (to move it through the edit controls) and walk around till I find the right spot. Generally by then I have an idea in mind... If it is not within a few feet, it seems to cause my client to crash. I had it happen twice today. >.<

  9. #9
    Rift Chaser JaydedRIft's Avatar
    Join Date
    May 2014
    Posts
    336

    Default

    Agrona: Often times, when it's that bad, my character also has green lips. I then have to pretty much restart my whole client, in order to get everything back to normal. LOL

    ROFL yep I've had those ugly green lips myself!

    I notice the longer you are in dimensions, the icons for lighting, fires ect start to show more. I also restart Rift when this happens & it seems to be a simple yet short fix.

  10. #10
    Rift Chaser JaydedRIft's Avatar
    Join Date
    May 2014
    Posts
    336

    Default

    Quote Originally Posted by Teslachu View Post
    Well thank you so much for the advise. It is good to know its not just me. I wonder if anyone else is having the same crashing issue I have. Sometimes I place an item down, decide I dont like it in that area, so I hit #4 (to move it through the edit controls) and walk around till I find the right spot. Generally by then I have an idea in mind... If it is not within a few feet, it seems to cause my client to crash. I had it happen twice today. >.<
    I had this a while back Teslachu. It was so bad then, that everytime I placed something & closed the edit window I would crash. I found as long as I left the edit window open it would not do it. I had to put a ticket in for them to fix it & they did.

  11. #11
    Telaran Teslachu's Avatar
    Join Date
    Jun 2014
    Posts
    66

    Default

    Quote Originally Posted by JaydedRIft View Post
    I had this a while back Teslachu. It was so bad then, that everytime I placed something & closed the edit window I would crash. I found as long as I left the edit window open it would not do it. I had to put a ticket in for them to fix it & they did.
    Well its picking the item up and moving it, while walking around.... Not pulling it up into my bag and then later replacing it. That is what I have found causes me to crash.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts