+ Reply to Thread
Results 1 to 10 of 10

Thread: Nightblade stealth/stun issue

  1. #1
    Shadowlander
    Join Date
    Aug 2010
    Posts
    32

    Default Nightblade stealth/stun issue

    Not sure if I have a setting causing this issue, but something I've noticed since alpha/beta testing.

    I picked Nightblade as my first soul. Four points in, I get Conceal, which is stealth. I also get Ebon Terror, which is a 20 m ranged attack that does one combo point and disorients the enemy for 2 seconds. At 8 points in the soul, I get Lost Hope, which is a 20 m "stun" that "incapacitates the enemy for 45 seconds" and it does not break stealth.

    So I'm in stealth, hit Lost Hope (have to be stealthed to use Lost Hope, btw) to stun the mob, and it either does what it is supposed to do (stealth doesn't break and mob is stunned) OR as soon as the stun lands, Ebon Terror INSTANTLY fires off and lands on the mob. I know it is Ebon Terror, because the mob has one combo point on it, AND the mob is wobbling around for 2 seconds because of the disorient.

    Are there other Nightblades noticing this, or do I have some setting that is linking Ebon Terror to fire off as soon as I hit Lost Hope? Thing is: it doesn't happen all the time.

  2. #2
    Shield of Telara baph's Avatar
    Join Date
    Dec 2010
    Posts
    761

    Default

    Never experienced this. Your keyboard sticky or something?

    Check your keybinds maybe? Any macros causing issues?

    Do you click the skills with your mouse?

  3. #3
    Shadowlander
    Join Date
    Feb 2011
    Posts
    30

    Default

    Never noticed this either you could possibly be queuing up ebon causing you to fire it directly after lost hope.

  4. #4
    Plane Walker Otiveht's Avatar
    Join Date
    Nov 2010
    Posts
    318

    Default

    Quote Originally Posted by Ruckus_Fivefingers View Post
    Not sure if I have a setting causing this issue, but something I've noticed since alpha/beta testing.

    I picked Nightblade as my first soul. Four points in, I get Conceal, which is stealth. I also get Ebon Terror, which is a 20 m ranged attack that does one combo point and disorients the enemy for 2 seconds. At 8 points in the soul, I get Lost Hope, which is a 20 m "stun" that "incapacitates the enemy for 45 seconds" and it does not break stealth.

    So I'm in stealth, hit Lost Hope (have to be stealthed to use Lost Hope, btw) to stun the mob, and it either does what it is supposed to do (stealth doesn't break and mob is stunned) OR as soon as the stun lands, Ebon Terror INSTANTLY fires off and lands on the mob. I know it is Ebon Terror, because the mob has one combo point on it, AND the mob is wobbling around for 2 seconds because of the disorient.

    Are there other Nightblades noticing this, or do I have some setting that is linking Ebon Terror to fire off as soon as I hit Lost Hope? Thing is: it doesn't happen all the time.
    Looks like a problem on your end and your keyboard. I do not have this issue at all.

  5. #5
    Rift Disciple
    Join Date
    Feb 2011
    Posts
    106

    Default

    Are you binding the commands to (modifier)+mouse button, because there's currently a control problem with anything bound to eg. ctrl+mouse4. If you're using a bind like that, pressing it will randomly cause the command to 'stick' and then act as if you are not holding down control.

  6. #6
    Rift Chaser Khroul's Avatar
    Join Date
    Jan 2011
    Posts
    307

    Default

    Yeah I've been running a full Assassin soul backed with 8 points in Nightblade to level, and I've never had that happen, not in the beta, or now.

    The only bug I've encountered is with Plane Shifting pulling rogues out of stealth if you spec into Rift barrier or Ruthless Stalker. --- You all should report this!

  7. #7
    Shadowlander
    Join Date
    Aug 2010
    Posts
    32

    Default

    Quote Originally Posted by baph View Post
    Never experienced this. Your keyboard sticky or something?

    Check your keybinds maybe? Any macros causing issues?

    Do you click the skills with your mouse?
    Once I log in, I'll check keybinds. I did not make any macros that I know of during alpha/beta testing or on live.

    And yes, I button mash with my mouse using left click. I move my toon around Telara with the 4 arrow keys.
    Last edited by Ruckus_Fivefingers; 02-28-2011 at 07:07 AM.

  8. #8
    Shadowlander
    Join Date
    Aug 2010
    Posts
    32

    Default

    Quote Originally Posted by Teoh View Post
    Are you binding the commands to (modifier)+mouse button, because there's currently a control problem with anything bound to eg. ctrl+mouse4. If you're using a bind like that, pressing it will randomly cause the command to 'stick' and then act as if you are not holding down control.
    I don't recall having a bind like that, but I'll check my settings and keybindings one more time to see if there is something that is causing this to happen. Thanks for the suggestion.

  9. #9
    Shadowlander
    Join Date
    Aug 2010
    Posts
    32

    Default

    Just to confirm: I do not see any keybindings that cause Ebon Terror to SOMETIMES go off after I hit Lost Hope...it's just weird, because it doesn't always happen. 50% of the time, Lost Hope lands, and the mob stays stunned and I stay in stealth. The other 50% of the time, Lost Hope lands, only to be instantly cancelled by Ebon Terror, and I do NOT hit any other keys or the Ebon Terror button to cast it. Ebon Terror just happens on its own free will, it would seem. I pop out of stealth, and the mob wobbles back and forth for 2 seconds with one combo point on it.

  10. #10
    Shadowlander
    Join Date
    Aug 2010
    Posts
    32

    Default

    I moved all of my "hidden" (stealth-only) attacks out of the "secondary" bar that only shows up when I'm in stealth mode. So far, that seems to have fixed the problem with Ebon Terror randomly firing off after I cast Lost Hope. Now that I have Conceal, Lost Hope and Ebon Terror on a totally different tool bar, this problem of Ebon Terror going off on its own has not happened.

    Is there some sort of a hidden setting on this toolbar that I do not know about that might be causing this stealth bar to bug on me?

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts