+ Reply to Thread
Results 1 to 5 of 5

Thread: Ranger Pets are broken all together.... 2016 ? Hows that possible ?

  1. #1
    Telaran
    Join Date
    Jun 2011
    Posts
    85

    Default Ranger Pets are broken all together.... 2016 ? Hows that possible ?

    Non of my Ranger pets works as it should

    They stand around .. do not use their skills

    They get stuck and stop using skills

    The ranged pet stops using skills

    Happens everywhere ... Instant Adv. , Solo play etc etc

    So far the Rogue is the most bugged class i have played compared to mage and cleric...

    These pet problems shouldnt exist anymore since the game was released 2011 right ?

    So 5 years ???? and pets are broken like this and no fixes yet ???

  2. #2
    RIFT Guide Writer Maltie's Avatar
    Join Date
    Jan 2011
    Posts
    743

    Default

    Yes, Rogue pets often have the issue of just not responding, its been like that for ages, I agree that it should be fixed but by simply putting petfollow and petattack commands into your macros, that fixes the issue.

    As an example;

    #show Fragmentation Sticky Bomb
    suppressmacrofailures
    petfollow
    cast detonate
    cast Fragmentation Sticky Bomb
    cast quick shot
    petattack

    You *can* go as far as putting the individual pet attacks in there as well, but I've not seen it to be an issue. But if you wanted to you would just put petcast <ability name> at the bottom of the macro for each of the pets ability, in order of damage. The charge would be at the top.
    Last edited by Maltie; 10-14-2016 at 10:24 PM. Reason: I can't spell
    Nixia@Greybriar]

    Quote Originally Posted by Cruzito View Post
    its actually 4 buttons. Let me know when you learn how to rogue

  3. #3
    RIFT Guide Writer huangchingho's Avatar
    Join Date
    May 2016
    Posts
    481

    Default

    Quote Originally Posted by Maltie View Post
    Yes, Rogue pets often have the issue of just not responding, its been like that for ages, I agree that it should be fixed but by simply putting petfollow and petattack commands into your macros, that fixes the issue.

    As an example;

    #show Fragmentation Sticky Bomb
    suppressmacrofailures
    petfollow
    cast detonate
    cast Fragmentation Sticky Bomb
    cast quick shot
    petattack

    You *can* go as far as putting the individual pet attacks in there as well, but I've not seen it to be an issue. But if you wanted to you would just put petcast <ability name> at the bottom of the macro for each of the pets ability, in order of damage. The charge would be at the top.
    Petcast commands will stop working occasionally, that's why I don't recommend using them.
    Ranger Pets are broken all together.... 2016 ? Hows that possible ?-21.png
    Safer way is to take petfollow and petattack commands. In addition, to ensure your pet does not stuck, add these commands to every single macro so that when the pet do bugged out it will reset the pet immediately. It's also great for target-swapping. Moreover, with petfollow commands, it enables your melee pets' Charge ability which is approximately 1% of your total DPS. (1% more DPS bois)

    I do agree that there is the lack of indication in clarifying known bugs, Devs should at least make a sticky thread or announcement with how to solve these issues temporarily instead of players spreading the words voluntarily.
    Last edited by huangchingho; 10-15-2016 at 09:41 AM.

  4. #4
    Champion
    Join Date
    May 2011
    Posts
    593

    Default Pets

    I'm running a 61 Ranger, and have used the small boar since the beginning, and eventually switched over to the greater boar (can't remember exactly what his name is).

    In all the months since I've been playing my rogue, I've never noticed any issues. From the time I fire my first shot, the boar takes of and doesn't stop till the enemy is dead. Same with the greater version.

    Then, yesterday, I read a post that said "make sure to right-click on the pet abilities to make them active."

    On my pet bar (not counting the attack, follow, and stay icons/buttons, and the aggressive, passive and third icon/button), I have 3 pet abilities, but one was not active, so I right-clicked it, and since I did that, I've had several instances where the pet goes on the attack, and if there are multiple enemies, after I kill the first one that he was tanking, he just stands there and doesn't move.

    Even clicking the Attack icon doesn't move him. It's not until I kill all the enemies, that he returns to me.

    So, I'm wondering if there's an issue with that third icon/button? I'm going to figure out which button it was and play around and see if I can duplicate the issue, or if it goes away after I make the ability inoperative.

    I'll update this probably tonight after I'm done playing.

  5. #5
    Champion
    Join Date
    May 2011
    Posts
    593

    Default

    Sorry, I'm a few days late.

    After some experimenting, I was not able to determine the cause of the sudden issue of the pet just standing there.

    It doesn't happen in 1v1 fights, only when there are multiple enemies. After the first enemy is killed, the boar just stands there and doesn't do anything, and I cannot get him to re-enter the fight.

    All my other characters with pets (mage, cleric, etc.) doesn't have this problem.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts