+ Reply to Thread
Results 1 to 6 of 6

Thread: Splinter Shot/Imp Quick Shot not proc'ing Blood Rage 3/3 ?

  1. #1
    Prophet of Telara Friar Tuck's Avatar
    Join Date
    Jan 2011
    Location
    Australia
    Posts
    1,089

    Default Splinter Shot/Imp Quick Shot not proc'ing Blood Rage 3/3 ?

    I'm not seeing any indication that Splinter Shot (Causes the target to bleed for wep dam + phys dam over 10 sec) is proc'ing Blood Rage. Same with Improved Quick Shot 3/3 (100% bleed chance). Have never paid much attention before - is there a blood rage buff or is the increase implicit? Or is it a known bug :/ ?

    Any info appreciated.
    My shiny carapace is cracked. I should have never left the sea. Krugon.

  2. #2
    Prophet of Telara Friar Tuck's Avatar
    Join Date
    Jan 2011
    Location
    Australia
    Posts
    1,089

    Default

    Ok, update. Since writing this my pet snuffed it and the newly summoned pet is getting the blood rage buff come up exactly as intended on splinter shot and quick shot.

    No idea why that should be. [Edit: ie why it was not proc'ing blood rage before. Will keep an eye on it and see if this one loses the blood rage abil at some stage and then bug it]
    Last edited by Friar Tuck; 07-10-2011 at 04:29 AM.
    My shiny carapace is cracked. I should have never left the sea. Krugon.

  3. #3
    Prophet of Telara Friar Tuck's Avatar
    Join Date
    Jan 2011
    Location
    Australia
    Posts
    1,089

    Default

    Just another update, this seems to be an issue. Hopped on the same toon again today and experienced the same thing - blood rage not proc'ing from Improved Quick Shot or Splinter Shot.

    Dismissed the pig and summoned a new one and that immediately was proc'ing blood rage.

    Seems that 'old' or carryover summoned pets from previous gaming sessions lose the ability to proc blood rage on the next log in. Am going to bug it.

    No one else have this happen?
    My shiny carapace is cracked. I should have never left the sea. Krugon.

  4. #4
    Telaran JohnD212's Avatar
    Join Date
    Feb 2011
    Location
    New York City
    Posts
    76

    Default

    Interesting...I've been having problems with Bloodrage not working but will try to resummon him later to check it out. I sure hope this helps.

  5. #5
    Telaran JohnD212's Avatar
    Join Date
    Feb 2011
    Location
    New York City
    Posts
    76

    Default

    Yep...I found this to be true. At least now I know how to make it work even though it means a little more work.

    Trion...please fix this.

  6. #6
    Plane Walker
    Join Date
    Mar 2011
    Posts
    461

    Default

    Its a bug that has been around for awhile. I believe its on every zone in you should re-summon your pet for some dumb reason.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts