+ Reply to Thread
Results 1 to 6 of 6

Thread: Piercing Beam not active....???

  1. #1
    Xem
    Xem is offline
    Soulwalker
    Join Date
    Mar 2013
    Posts
    11

    Default Piercing Beam not active....???

    I have put a point into Piercing Beam (Harbinger) and even 3 points into Intensity but it shows Piercing Beam greyed out. When I try to use the ability it says Invalid Ability.

    I made a macro:

    #show Storm Slash
    suppressmacrofailures
    cast Vorpal Slash
    cast Storm's Fury
    cast [notactive] Piercing Beam
    cast Storm Slash

    and it seems that using [notactive] makes it work, but I dont know why or how....

    Anyone have any information on this?

    Thanks!

  2. #2
    Sword of Telara meoka2368's Avatar
    Join Date
    Jan 2011
    Location
    Vancouver B.C., Canada
    Posts
    844

    Default

    The only thing I know that will make it say that it is invalid is if you're targeting something that you cannot attack (like a friendly NPC) or have no target selected.

    The [notactive] shouldn't make a difference for this, as it's only supposed to be used for things like charge drainers. Doesn't even work on buffs.

  3. #3
    Xem
    Xem is offline
    Soulwalker
    Join Date
    Mar 2013
    Posts
    11

    Default

    Quote Originally Posted by meoka2368 View Post
    The only thing I know that will make it say that it is invalid is if you're targeting something that you cannot attack (like a friendly NPC) or have no target selected.

    The [notactive] shouldn't make a difference for this, as it's only supposed to be used for things like charge drainers. Doesn't even work on buffs.
    Thanks for your input, but I am not a fool. I am certainly not targeting friendly NPCs or other creatures I can not attack and expecting the ability to work.

  4. #4
    Plane Walker
    Join Date
    Jan 2011
    Posts
    467

    Default

    try clearing that spot on your hotbar then dragging it in from the spellbook again, sometimes that fixes invalid abilities.
    Mantissa@Greybriar 7/8 raid tiers cleared <Rekt>

  5. #5
    Xem
    Xem is offline
    Soulwalker
    Join Date
    Mar 2013
    Posts
    11

    Default

    I logged out of the game and then back in and it fixed it.

    Very odd!

  6. #6
    Soulwalker
    Join Date
    Feb 2011
    Posts
    15

    Default

    Yeah, there seems to be some arcane issue with spells being greyed out on hotbars for no reason; zone or change souls or relog usually fixes it for me.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts