+ Reply to Thread
Results 1 to 4 of 4

Thread: Fire Spells not

  1. #1
    Telaran
    Join Date
    Jun 2011
    Posts
    55

    Default Fire Spells not

    Working as intended?

    So I've been hitting the dummy in my pyro/ele spec (spec here), and I've noticed my fire spells are not doing the damage they should be.
    34 points multiplied by the burning bright bonus of 1.2% per point gives a 40.8% bonus to fire spells.

    Flame Bolt base damage: 154-158
    Bonus from Burning Bright: 40.8%
    Expected Flame Bolt damage range: (154*1.408) to (158*1.408) = 216.8 to 222.4

    So why is my max hit 207? http://i79.photobucket.com/albums/j1.../FlameBolt.jpg

    (The ignite casts were in there just to keep me in combat while I waited for Flame Bolt to come off cooldown and the buff to drop off, but that too is hitting for less than it should.)

    My only theory is that something is wrong with Burning Bright. I thought perhaps the training dummies had resistances, so I tried it on a naked player. Again, it hit for less than expected - around 165 - which, even accounting for the fact that burning bright gives only a 20% bonus to players, is way off.
    Last edited by Aarpia; 07-01-2011 at 06:34 AM.

  2. #2
    Prophet of Telara
    Join Date
    Feb 2011
    Posts
    1,037

    Default

    Tooltip has already applied the 40% to the real base damage.

  3. #3
    Telaran
    Join Date
    Jun 2011
    Posts
    55

    Default

    Then why am I doing 207 damage with 0 spell power on a tooltip that reads 158 damage?

  4. #4
    Prophet of Telara
    Join Date
    Feb 2011
    Posts
    1,037

    Default

    Because even naked you have 54 spell power.

    Edit: I should have noted above that the tooltip actually shows the pvp damage, for whatever reason.
    Last edited by Kazzin; 07-01-2011 at 12:44 PM.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts