+ Reply to Thread
Results 1 to 7 of 7

Thread: Deathly Calling not applying?!

  1. #1
    Soulwalker
    Join Date
    Jan 2011
    Posts
    19

    Default Deathly Calling not applying?!

    I'm trying necromancer, and I've specced the double deathly calling application. I'm not seeing the debuff, so then I decided to just test based on the damage output, and deathly calling isn't applying at all from what I'm seeing.

    I should be getting a stacking 10% bonus plague bolt damage increase per cast, but from first cast to last, it always falls in the same damage range.

    Anyone have any idea what the status is on this bug? Given that deathly calling appears to be critical to quite a bit of necromancer's abilities, it seems to be a major one.
    Last edited by Rekatan; 03-12-2011 at 05:29 PM.

  2. #2
    Shield of Telara wallweasels's Avatar
    Join Date
    Feb 2011
    Posts
    742

    Default

    I'd call you crazy but I swore this was happening a few days ago. I was in stillmoor and it just wouldn't stack...then maybe 30 minutes later it would. Same Mobs...server didnt reset or anything...just suddenly worked again
    the PTS exists for a reason people. Go on, give your feedback, and help make RIFT a better game.
    All the world will be your enemy, Prince of a Thousand enemies. And when they catch you, they will kill you. But first they must catch you; digger, listener, runner, Prince with the swift warning. Be cunning, and full of tricks, and your people will never be destroyed.

  3. #3
    Soulwalker Sylvanna's Avatar
    Join Date
    Mar 2011
    Posts
    2

    Default

    It works for me,just look on you're pets head.
    You can't be the best until you've meet someone better than you!

  4. #4
    Soulwalker
    Join Date
    Jan 2011
    Posts
    19

    Default

    ha I swear I'm not crazy. Time to relog and see if that fixes it =P

    It worked for me back in beta when I tried necromancer... *baffled*

    *EDIT*

    That fixed it!! If anyone gets this bug, just relog realquick
    Last edited by Rekatan; 03-12-2011 at 05:55 PM.

  5. #5
    Plane Touched
    Join Date
    Feb 2011
    Posts
    239

    Default

    I was having the same issue and relogging didn't fix it. I saw someone else say that they had to relog and dismiss/resummon their pet to fix it. Not sure what's causing it, but this is one weird bug. I wonder if it's just a display bug or if the debuff is actually not getting applied. Didn't see anything in the combat log, but I'm not sure if it's supposed to show up there.

  6. #6
    Shadowlander
    Join Date
    Jan 2011
    Posts
    37

    Default

    Stormcaller has the same issue, with Hypothermia and Electrified. Not sure if it's display only or application bug.

  7. #7
    Rift Disciple Xruptor's Avatar
    Join Date
    Jan 2011
    Posts
    101

    Default Yep

    Yeah Deathly Calling is having issues. I've reported it but you never know if they ever look at it.

    Anyways, there is another thread on this topic as well: http://forums.riftgame.com/showthrea...hlight=deathly

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts