+ Reply to Thread
Results 1 to 3 of 3
Like Tree1Likes
  • 1 Post By Gurash

Thread: The Devil Who Would Be King

  1. #1
    Soulwalker
    Join Date
    Oct 2020
    Posts
    11

    Thumbs down The Devil Who Would Be King

    The quest in Ashenfell called "The Devil Who Would Be King" is malfunctioning on my level 70 rogue. You initially receive the quest from Carli in Ashenfell, at 2654, 4319. The first quest objective is to "Enter the portal" found at 2931, 4445. Once you enter solo-dungeon, the quest objective updates to "Complete King's Fall." Inside, Carli is standing there, ready for you to talk to her. This is where my problem begins. Carli will not talk to me. There's no chat bubble icon over her head, and right-clicking her does nothing. I have abandoned the quest multiple times. I have manually "Reset Instances." I have abandoned the quest and waited until several hours after the weekly reset to try again. Nothing had worked so far.

    What caused the error, I believe, is that I was questing with my wife. We were partied, both with the quest, and both next to the portal. She went in, and I got credit for "Enter the portal." I tried going in, but it said the instance was full. Once she was done, I went in, and proceeded to work through the solo-dungeon the usual way, killing the boss. However, I never received credit for doing so. This is when I first abandoned the quest and tried again... and again.

    Any help would be appreciated. Thank you.

    Notes:
    - This becomes the daily Ashenfell solo-dungeon that you enter through the portal at Thedeor's Spear.
    - I have completed this on another character on the same account and the same shard.

    I have tried:
    - Abandoning quest, trying again
    - Abandoning quest, logging completely out, waiting minimum of 5 minutes to get quest again
    - Abandoning quest, waiting until weekly reset to try again
    - Reset Instances manually

  2. #2
    Soulwalker
    Join Date
    Mar 2021
    Posts
    1

    Default Same Issue

    I am surprised no one ever replied to your post. I am having the same issue and have tried the same thing you did nothing seems to work

  3. #3
    Soulwalker Velanor's Avatar
    Join Date
    Nov 2016
    Posts
    8

    Lightbulb

    One thing you might check, and it has bitten me a couple of times doing older quests, is your dungeon difficulty settings. More than once, I'd be looking for an npc, or whatever, and find that I had it set on expert. Back out, change to normal, and things worked as expected. Vice versa, there's some quest that require expert as well. Worth a look maybe.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts